Sync to Onedrive stopped unexpectedly. Worked fine for me years

I found out by coincidence that my backup sync from TrueNas to Onedrive has stopped working. I tried to set it back up but it doesn’t work anymore. It connects and even creates the backup folders Onedrive but doesn’t copy the files themselves. Any others that have experienced this and found a fix?

Correct, Onedrive sync support was removed in 23.10 because the code it relied on was outdated. You can read about it in the old archived forum as well as see what workarounds other users came up with.

Your milage may vary:

it’s a bit of mystery to me. First of all, i run Core. Secondly, it ran perfectly fine until a month ago.

In that case I don’t know why, although I suspect the outdated code could cause issues in Core as well.

1 Like

Also likely MS did something on their end to stop depreciated code from working or connecting.

What you may need to do instead, is if you have a device on your network that has said OneDrive files on it - just sync direct that systems OneDrive directory to your TrueNAS.