System will not boot with drives in bays

I have a supermicro x10sdv-4c-tln and have had boot challenges with that too. I’ve found that when chosing boot devices it seems to lose my NVME drive in the list of available options when all my other drives are inserted.

After much messing around over the years I’ve had this board I now always have it set to UEFI only (No legacy) Choose UEFI Hard disk as first boot priority, and even consider removing all the other drives from the system when initially installing. I use a bootable UEFI USB for install. As my HBA supports hot plugging devices, i insert the rest of the drives once the system is up.

Once arrays etc all set up reboot and see if it boots OS. If not check the
UEFI Hard Disk Drive BBS Priorities option

Currently running Scale with no issues, but every time I have to re-install an OS on this board its always a little awkward…

Good luck!

I installed a new motherboard and I still have the same problem. I also realize that this started when I expanded one of the VDEVs to 6 X 10TB from 6 X 4TB. So I tried to boot with the 6X10TB drives disconnected and with my other two VDEV’s (6X6TB) in the bays. And it booted! So I think my 10TB drives are too big for my Backplane or too big for the 3 8-channel cards that connect to the backplane (not sure what those are called). But then if I put the 10TB cards back into the bays one by one with Truenas running the system does not show a Pool. The system does show the drives just not the pool. So do I need a different backplane or the cards that connect to it?

Another update:
So after determining that my server hardware was incompatible with my 10-terabyte drives I purchased another newer 24-bay server. My new server now boots TrueNAS Core with all of the drives installed in the bays. However, once it’s up and running the GUI under “Storage” > “Pools” has no pool (and none available to import) and the only drive that is listed under “Drives” is my SSD that has the OS on it. The drives and their serial numbers appear on BIOS boot. Although it says “Number of online units: 0, available drives: 18”. But I’m not sure if they appear on OS boot. It scrolls pretty fast. Also if I pull the 6 10TB drives the BIOS boot still displays “Number of online units: 0, available drives: 12”. So it is not an incompatibility problem with the hardware and the 10TB drives anymore.

One problem solved.

So I need help getting either my hardware to recognize the drives as “Online”. And/or then getting TrueNAS to recognize my drives and recognize the pool which is/was 3 vdevs of 6 drives each.

Thanks in advance.

You cannot use a 3ware SATA RAID Controller with TrueNAS.

1 Like

OK. That identifies the problem. Is there a similar controller that would be compatible with my backplane that I can purchase? Or what specifications can I search for to replace it with something compatible?

I’m seeing LSI 9750-4i 4 Port 6Gbps PCIe 2.0 x8 SATA / SAS Raid Controller Card w/ BBU on Ebay. Would something like that work?

No. Any mention of “RAID controller” is a red flag, and “battery” is a definite no-go. (Not to mention that the 9750 number with PCIe 2.0 looks suspicious…)
Look for a plain HBA based on LSI 2008 (9200), 2308 (9211), or 3008 (9300).

My server is back up and running and all of my data is intact!

I purchased a new LSI 6Gbps SAS HBA 9211-8i, and It recognizes my 10TB drives.

It was difficult to describe my problem since I am not very knowledgeable with hardware and the TrueNAS OS.

Thanks, Thanks, Thanks to all who helped here.