System will not boot with drives in bays

My system will not boot with my data drives (Pool Drives?) in their bays. If I remove all of the storage drives the system will boot to my 64GB SATA SSD. I have been in the BIOS and I have assigned the boot drive to be the 64GB SSD but no matter which SATA plug I use on the motherboard if the storage drives are in I end up on the screen in the photo. The server is a Supermicro H8DME-2 with 24 bays.

In case the photo did not upload the screen says:

BIOS drive C: is disc 0
BIOS drive D: is disc 1
BIOS drive E: is disc 2
BIOS drive F: is disc 3
BIOS drive G: is disc 4
BIOS drive H: is disc 5
BIOS drive I: is disc 6
BIOS drive J: is disc 7
BIOS drive K: is disc 8
BIOS drive L: is disc 9
BIOS drive M: is disc 10
BIOS drive N: is disc 11

Thanks in advance.

What OS is that?
Drive letters are typically only a thing in DOS or Windows.

Try disabling legacy/CSM boot and using UEFI only. Might need a reinstall.

1 Like

Thanks. I will try that.

I can’t find that setting anywhere in my BIOS.

Weird. Advanced Settings - BIOS features - try to switch the Linux/other setting for the OS.

Tried that before posting here.

The Board is a H8DME-2. It was incorrect in my original post. Now corrected.

Did you do a BIOS or an UEFI installation? Does the installer even give you an explicit choice? I honestly do not remember. If it does, try a reinstall with the other method.

I have tried using every SATA port on the MB. Under the Boot menu, it shows the SSD that my OS is on, and I have disabled any other drive options for booting. I have re-flashed my BIOS with the latest for the MB. I have put the SSD into the 3.5-inch storage bays. (All of them). If I pull my data drives or pull the cards that go to the backplane, the system boots every time. This all started about two weeks ago. It did the same thing one evening with no success in booting. Then the next morning after being off all night it worked perfectly in the morning. This system has been running for years with no changes other than updating to the latest Truenas version. I am now suspecting that my MB is bad.


Same as last posting: switch from BIOS to UEFI or the other way round and try that.

This is not a new install. It has been working for years. It will not do an install if the storage drives are connected. The USB installer ends up at the same screen. And the system boots every time without the storage drives or cards.

I can pull the storage cards. (Eaiser than pulling 18 drives) and then install Truenas in either UEFI or BIOS. How do I know which one I have now so I don’t have to try both?



gpart show

Then for your boot drive look if there is a “freebsd-boot” or an “EFI” partition on it. The first is BIOS, the second (obviously) UEFI.

For SCALE - sorry, the Debian Linux equivalent which I don’t know from the top of my head. The key is the partition table. You might want to google how to print that for your disks.

Also the command will show you the partition tables of all your data drives. If they are not factory new there might be some leftover crap on them that makes the BIOS think they are bootable.

If that is the case and if this is a new installation without data on it, it might help to erase all data drives.

dd if=/dev/zero of=/dev/ada1 bs=1m
# assuming ada1 is one of your data drives and if this is FreeBSD
# repeat for all of them - you can run these jobs in parallel.
# Linux - again, please research the proper device names, something like sdb and some such, then the command is essentially the same
# IIRC Linux does not like bs=1m but wants bs=1024k

It is Core. I will work on that. Thanks.

Here’s what I got from “gpart show”:

root@freenas:~ # gpart show
=> 40 125045344 ada0 GPT (60G)
40 1024 1 freebsd-boot (512)
1064 125044312 2 freebsd-zfs (60G)
125045376 8 - free - (4.0K)

Is the “- free -” supposed to be that small?

Since it is a BIOS boot, I am now trying to do a UEFI install on another SSD.

Yes, that’s wasted space.

It’s “free” like in “not available for anything in the OS”. It’s due to rounding of partition sizes. It’s not the free space inside your OS partition.

Understood about “free”.

The system will not boot at all from a UEFI install. With or without the data drives.
As the installer said “Boot is recommended for Legacy and Enterprise hardware” and this is probably both of those.

I suspect a failed MB at this point. And the clue is that 2 weeks ago it did this for 3 hours, then after a whole night powered down it worked fine in the morning with no changes to anything other than the temperature of the hardware in the morning.

Thoughts? Trying a new to me used Motherboard will only cost about $70 delivered.

This is documented in the FreeBSD forums and seems to rarely occur, however the solution, I didn’t find one. Since the issue is FreeBSD, recommend you try SCALE.

How is the bootable installation device created? It could be related to that but I don’t know. I like to mount the ISO and load or use a CD-R.