Tailscale with truenas application ports

So i got my TrueNAS-SCALE-23.10.2 working. Immich, tailscale, and Plex. What I cannot seem to do it get access truenas apps with tailscale. I saw some other things on here but nothing seemed to work.
I have subnets and exit node enabled in tailscale.
Enabled - Advertise Exit node
Enabled - Userspace
Enabled - Host network
Advertise Routes I added my home ip network.

I can access my truenas via tailscale but thats it. It does not like it when I add ports.
I tried to use nginx proxy manager to add the port that way like other applications. But any apps like immich do not work.

Any one have any ideas?


You need to add your IP address of the box to the IPs you route to.

So my truenas is on so I add this to the available routes. Then everything works like magic. All your apps will be accessible remotely.

This is because your truenas apps are wired to the LAN address, not the tailscale address.

You’d think this would work but it doesn’t so this workaround solves the problem.

Just make sure you add the route to Tailscale as a /32, ie., so you’re only routing to that specific host over Tailscale. is an RFC1918 address range and likely to be used extensively in other locations. If you’re on someone else’s LAN (ie. a friend’s house, work, coffee shop, etc.) and it’s using but you route all that traffic over your tailnet things will break.

So I changed it from to the actual ip of the truenas. I have tailscale Subnet routes pointing to the actual ip of my truenas.

I also added Advertise Routes the same ip with /32 at the end in truenas in the tailscale part. but its still not working. I always get refused to connect.
I should also note i am trying to connect to immich app on my truenas.

You need to accept the advertised routes in your main tailscale control panel (web interface to your tailscale account).

then make sure they work.

I did it’s there.

so you manually accepted in the tailscale web GUI, NOT the truenas GUI?

Can you show me the screenshot of the confirmation?

It should look like this:

See below

I guess this is something that cant be done.