Transfer speed 100mb to 10mb

hi, im new to trunas and after i install truenas core et set it up my transfer speed was about 100mb so i was happy with that, but 1hour after, for some reasons the transfer speed slow down to 10mb, i notice that the transfer speed change after i install plex but im not sure if this is the reason or if i did something wrong.
Im using a fanxiang S101 128Go SSD for truenas
and a segate of 1to for the storage.

Are you transferring the same types of files?

The HDD does not like many small files due to all the overhead that they entail. Plus Metadata, etc. Large files are much easier for HDDs to write and read, hence those speeds will be a lot higher. Recordsizes, encryption, compression, etc. can also impact performance.

yes im transferring the same files, a video of 350mb.
what I don’t understand is that before this problem I was transferring the same type of file without any problem at 100mb, I don’t see what could have caused this drop in such a short time.

If the pool is getting fuller, then the file system has to hunt for open blocks. How full is that 1TB drive? Remember, TrueNAS really doesn’t like the pool to be more than 80% full, ever.

My pool is new, there is no data in it

Can you check your network connection? Under dashboard review the network widget, does it display 1000 Mbits or 100 Mbits?

Under scale I had occasionally dropouts where the network interface would only be recognized as 100 Mbit.

1 Like

First of all im on Truenas Core.
And im not sure if i understand where to check that so here some screenshot

Try plugging and unplugging the cable on your NAS and Switch and see if it changes.

I haven’t had the problem in an eternity, I suspect it was the switch (which got replaced somewhen down the road).

1 Like

it works my transfer speed is back to 100mb!
i feel so stupid it was so simple, i dont know why i didnt try before
Thanks you man


If you didn’t know where to look for that information it’s not that obvious.

Feel free to mark this thread as solved then.

Are you using a switch? See how frequently this occurs, for me I’m pretty sure a different switch solved the problem. You can also try and set the speed for the lan port in the switch manually rather than leaving it on auto.

1 Like

yes im using a switch.
Im gonna check if i can change that

1 Like

It could also be your Ethernet cable. One broken wire in there and the connection will drop to fast as opposed to gigabit.

1 Like

100baseTX is limited to 100mbps, about 10MiB/s

Unplugging something and plugging it back in again… Hm.