Transitioning to new network subnet after the fact

Dumb question: I have a very simple TrueNAS Core box, running a version or two back from latest. Our router died, and I had to bring in a new router, and I let the new router default to 192.168.1.x (previously the network had been subnet 10.0.1.x). So with the change the TrueNAS box became unreachable (it had been on a manual assigned address like

The box is an HP N40L, which supports a console if you hook up a keyboard and display, so I did that. Then I added an ethernet cable direct from the TrueNAS box to a port on the router. Booting with the keyboard and display connected got me to the menu where I could choose “shell access.” Within shell I’ve tried editing /etc/rc.conf, adding a line to try and configure the network with DHCP to at least get it on the network:


But… no joy. When I run /etc/netstart it says network is unreachable next to the gateway address

And of course, looking in the router’s table of connected devices I don’t see the mac address that ifconfig gives me on the box.

Any suggestions, other than just download latest Core and re-install, following the network prompts in setup? Thanks for your advice.

On your desktop system configure an IP address in the 10.0.1.x network as an alias/additional address. You can then access the UI.