TrueCharts apps not working after installation. TrueNAS apps work

Hi guys,

I’m pulling my hair out atm. I have a HP ProLiant Microserver gen8 and did a fresh install of the latest release of TrueNAS. I tried to install the Truecharts catalog, which took ages to install, as I outlined here: TrueCharts catalog stuck @40% for more than an hour - Apps and Virtualization - TrueNAS Community Forums

But, after installation of the Truecharts catalog and installing a couple apps (which also takes ages to complete) the apps do not work. The TrueNAS catalog and apps work as expected.

I have no idea why the Truecharts catalog and apps take ages to install and the apps do not work. I tried lots of things, but can’t figure out how to fix this.

Any ideas?

Did you follow their minimal Setup Guide and installed the required Operator Apps and Open EBS before installing any other App AS described in their Setup Guide? Truecharts App rely on pvc storage and with dragonfish iX removed their open-ebs Implementation and truecharts introduced their own to provide it.

See Getting Started | TrueCharts Charts and follow their minimal Setup Guide before installing any other App from their repo

1 Like

Hi Lars.

Thanks. Yeah, I just read that last night. I used TrueNAS SCALE v23 before and that wasn’t necessary then.
I will try that. Having said that, it still doesn’t explain why installing the Truecharts catalog takes over 2 hours to complete.
Any ideas there?

Similar problem, new install on truenas scale. And truecharts will not connect. Followed procedure from truecharts web page.

" * Make sure you have a working Internet connection and can reach github, truecharts, and tccr from the host system."

I have internet and can ping github and truecharts, but there is no response from Maybe the problem is truecharts and not truenas.

[EFAULT] Failed to clone ‘GitHub - truecharts/catalog: This is JUST the catalog, please refer to truecharts/apps for the actuall app code!’ repository at ‘/mnt/truenas-pool/ix-applications/catalogs/github_com_truecharts_catalog_main’ destination:

Saw some posts on their support discord recomending to tick the force checkbox when adding the catalogue, cant rememher why thought.

Force checkbox did not help.

Haven’t tried the ‘force’ checkbox yet. I just removed the catalog and re-added it again, so am unable to try atm. It’s been stuck again with 100% CPU for the last hour… :frowning:

The website is down here as well.

What’re your system specs? They may be too low.

Took me 25 mins from start to finish on an i3-10105 to add the TrueCharts catalog, 5 threads were @ 100%.