TrueNAS can't connect to active directory

I have a windows server setup in a vm inside truenas, and I run active directory on that.

When I try to connect my truenas setup to the active directory it just hangs and doesn’t give me any error or anything, the page just stays blank. Please help!

Don’t do that. You have a chicken and egg problem now. TrueNAS needs AD to be up to boot fully. The VM which runs AD won’t launch until TrueNAS is booted fully. AD should always be hosted externally.

1 Like

okay so if this wasn’t a server with active directory on, how do i get truenas to ping a vm? i tried to ping the domain and ip of the vm and truenas is stating that the ‘destination host is unreachable’

You have to create a bridge device so they can talk to one another. Details here:

yeah ive seen that and it says i have to set static ip and turn off dhcp. everytime i do that, i cant actually access the truenas gui and create the bridge, or do anything.

Have you watched the official[1] unofficial guide on how set up a bridge?

  1. Not really, but very informative. ↩︎

1 Like