TrueNAS CORE boot problems in HP Proliant Gen8


I just acquired an HP Proliant Gen8 Microserver to use as a home server.

I installed TrueNAS CORE in a drive I added to the SATA port on the motherboard.

The system boots without any issues, but then when I add other drives in the bays, the system won’t boot any more.

I’m seeing the message “Non-system disk or disk error”.

Any idea how to select which drive to use to boot?


I remember that being a little tricky,

There is a SATA port on the mainboard, that was meant to be used for an ODD drive. Due to a kind of bug, it is not possible to set this a boot drive. Search for HP Microserver Gen8 boot from ODD. There is a pretty good thread on the omv forums, with input from someone actually working at HPE.

IIRC there are one or two different solutions. I installed grub on a SD-card, which then points to the boot drive. I do not remember the details, and just hope it never breaks… :woozy_face:

I managed to solved it thanks to the tips here: Microserver Gen8 - Boot order from different SATA ... - Hewlett Packard Enterprise Community

I changed the setting in the BIOS from AHCI to Legacy, then after I restarted I could see two SATA controllers. Then I chose the second one and could boot again.

1 Like

Mmmh, but legacy actually means the proprietary raid function is activated, and it is not just passing through the disk? Not sure this is a good thing in combination with ZFS, even if it is soft raid with the HP B120i.

Here are the instructions I used,, and there is a thread on omv forums, hpe proliant servers, created by Spy Alelo.

Thanks for sharing, I’ll have a look.

I’m going to reset settings, enable AHCI and to try to make this work using a SD card.

Any tips @prez02? To be honest, I’m not very experienced TrueNAS and Linux. To start with, I’m running the first command dd if=/dev/zero of=/dev/... but taking ages.

Not sure if I’m doing something wrong.

Okay, this is another description, in German, but maybe you can google-translate it? It also offers a download of a ready made image to install grub on a sd card.

Apart from that, not sure the zeroing is necessary, and if you have a large but slow sd-card, it probably takes quite a while?!

Thanks for sharing. Zeroing was not a good idea in this card, it’s still running and it will probably take all night.

We’ll see if the rest of the steps work, fingers crossed.

I may try with a USB stick, I cannot get the SD card to mount. :woozy_face:

I see the sd in the disk list:

But when I run fdisk I see the following:

Any ideas?

I tried with a USB stick and managed to make it work. Thanks for sharing the info @prez02, it was very helpful.

1 Like