TrueNAS Scale 1st Experiance ... Feedback

Hi 1st time poster on this Forum not 1st time poster on TrueNAS forums, got pointed to this forum trying to make this post on the Archived forum.

So this is just 'n general experience Dump of my 1st time installing TrueNAS Scale (i’m not convinced or impressed) compared to my 1st time with CORE.

So i’m basically 'n lower-intermediate experienced HomeLaber. I’ve run TrueNAS Core for close on 4 years + continually. I know enough to follow a decent guide, figure one or two things out that might be wrong or left out, but if thing Crap out completely i don’t have enough Linux / FreeBSD experience to go dig around. I setup a server the way i like it, i update it and i leave it alone otherwise. Being able to only afford one i can’t “Afford” to have it broken and not being able to use it while i dig around a try and fix it.

I run a HP Microserver Gen8, 4x 4TB HDD’s (DATA Z1), 1x 256SSD (Jail / APPS) in the CDRom bay on the internal SATA port, and a 32Gig SanDISK USB on the internal port for boot.

Form the word go i managed to get CORE installed on a flash drive (yes i said it’s not a good idea but it worked) and it ran like a charm. Nextcloud gave me a issue or two over the years but i always managed to get it sorted until a update August Last year couldn’t get it fixed all replies to similar issues said move to SCALE, CORE is getting limited to no updates for “APPS”

So after 9months of living with degrading experience i figured it’s time to take the leap an move to SCALE.

Friday evening i power my server down, unplug my all my drives, plug in a new flashdrive (if things go completely south i can just revert back) and the fun and games started. 1st attempts SCALE tells me Install FAILED, 2nd attempt SCALE installs but doesn’t boot, 3rd attempt SCALE says drive locked or something, 4th attempt scale FAILS. 5th attempt now i removed the flash drive and installed the old one that ran CORE for 4years no issues. 1st attempt SCALE fails. I try UEFI, Legacy, with a swap file, with out a swap file i get it to install and run 1 Time out of probably 10 + installs on the 1st flash drive i tried for the 2nd time. Only for APPS install to screw up and me having to reinstall (but i’m getting ahead of myself)

So eventually i go screw it stick a SSD in a USB external and SCALE installs instantly, boots up and runs.

Having already overwritten my CORE boot i figure screw it lets start completely fresh so i stick the old JAIL drive in, import my DATAPOOL and install PLEX. Followed a guide just to double check the permission settings and it works.

So next comes nextcloud. Firstly every single guide i find including the documentations on iX system documentation doesn’t match the version or the settings i get. I see i can select a older version but the versions in the guides is not available in the previous versions list and no matter what previous version i select and what settings i use the install button never becomes active except on the latest version.

So after a day and a half of installing nextcloud messing up something error messages reported in the little window next to the container is useless for google (or my googlefoo this weekend was empty) and reloading TrueNAS about another 8 time cause either the APP sits on Deploying refuses to stop, can’t get rid of it even if i remove the app pool format that drive and re-add it as a new pool the nextcloud “Deploying” just magically comes back.

Eventually i figure screw it do a Default settings install check if it works and then start changing one setting at a time. Default install works Happy Dance, but now my user data ends up on my small 256SSD. After another probably 5 times removing and reinstall nextcloud i eventually figure out what is causing it to fail i leave that on default point the user data to my datapool and it WORKS. I setup a account for me start syncing my phone data. Next i app plex again and system is running.

Now i get to the main reason for my post. After 3days of my server running like a dream again, i get home today see a update for nextcloud is available, click update and now i’m stuck again with a nextcloud that just say deploying i can’t stop it, i can’t rollback it, i can’t update it even though my TrueNAS alerts me everytime i loging that a update is available.

IDK, i’m not impressed and very disappointed. My 1st experiences with CORE i recommended TrueNAS to all my friends and even a few clients, SCALE so far i’ll rather tell them to go by a Sinology or similar NAS at least for now.

Sorry if this seems like mindless rant without much details but i needed to get this off my chest before i switched my server off and sold it.

If you need more info ask away i’ll answer when and with the info i can.

But that was my 1st Experience with SCALE i just hope for your sake it’s not more peoples and they just don’t complain and that i’m the idiot in the story and i did something wrong.

Thanks for reading …

Edit: Added a TAG and fixed a few spelling mistakes it was late / early when i wrote this


Your not alone so thought I would provide my recent experiences as well. I moved back to CORE stable and considering the number of issues being posted in the last couple of weeks, I will not be moving to SCALE until forced. I don’t have the time to debug stuff in my storage systems or worse the pools are not there tomorrow with the overnight backups.

Next, on the non-prod server, I thought I would give a go to the latest CORE nightly to give back to the community as requested by IX. Unfortunately, this was reverted to 13 stable in a few hours after discovery vm’s and the console no longer functioned (also reported in the community). Ticket response was vm’s aren’t supported. Fair enough but it was working. Indicative of the future support of CORE in my opinion. Resources are focused on SCALE RC bug fixes.

Not really sure what I am going to do as I am looking at HW refreshes and frankly was planning on staying with TrueNAS. Hard to make a strategic decision at this point.

Our use cases are simple:

  • Daily backup repo for Linux and Windows workstations via smb
  • Bunch of smb shares for music, pictures, and software repo. Pretty static and well served on the current network.
  • Copy of the lot on a second server for backup.
  • Two small vm’s for local dns.

Next steps… I reset the non-prod server with Ubuntu and will be investigating ZFS storage and see how that is developing with the latest releases. Then probably just load Debian stable and create lvm arrays (sigh) with samba, kvm for dns. Simple as it gets and then call it a day. It’s backup. Its boring.

Maybe the SCALE = CORE stability will be there by Q1 2025 at which time will see what to do with the production CORE system. I ditched QNAP years ago because of too many bells & whistles for TrueNAS. Being an old fart at unix, SCALE issues and the focus away from pure storage may have me looking elsewhere. Containers and media servers shouldn’t be on a NAS. They should consume NAS.


Thanks for the reply.

I can’t say i have a TrueNAS plan at this point for my home server.

Hardware wise i’m looking at buying a PCIe Card that can hold 2x NVME’s so i can run my APPS drive in Mirror, that will leave the internal SATA port open to keep the boot drive a normal SSD that i have in a tray in the CDRom bay.

That will cancel out booting etc from a flash driv. I had the same idea before on my core build but the SSD bay would have become a cache SSD.

My server is used:
1: For backups for my home PC, All the Phones and Tablets through nextcloud
2: Plex
3: Downloads

That’s what i did with it for 4 years of mostly peaceful running of it apart from nextcloud not resetting the maintenance mode flag after a update.

I’m not sure if nextcloud will work on CORE after a fresh install might be worth it to try on the flash drive again, but then i won’t be getting any core updates for the apps anymore.

For now i’ll go without nextcloud again till i can either get answers on how to fix it (i’ll post in the apps section later) or get the hardware i’m planning on adding.

Hopefully by the time i get the hardware i’ll have a better idea of where to go with the Software side of things. Maybe i should check if i can get one of the older laptops i have here up and running again, Install TrueNAS Core on my server let it just run storage en run plex and nextcloud through a windows notebook, IDK.

With how hard SCALE is pushed and how broken it still seems idk how they can what feels like force people to use it at this point.

Sorry i still wanted to add this.

As far as i understand CORE will be heading in a more Storage Management only direction and SCALE will become the more Do It All Version …

I could have it wrong but apart from VM’s CORE might be the place for you to stay if storage is your only and main aim for the server.

1 Semi decent “Server” running my storage and 1 or 2 apps is way more convenient than trying to afford 2 or 3 systems and splitting storage and app server up. But it might be the direction i go as well as mention in my previous reply.

I’m surprised you’ve had these sorts of issues installing, I can’t say I’ve ever run into them personally (only thing I can not speak to is Nextcloud as I’ve not deployed it before).

As you mention, CORE is both stable, and not going away. If it’s what you’re comfortable with and it fits your use-case, there’s not much of a need for you to migrate. Rather than heading in a “storage management only” direction, CORE has moved to a sustaining engineering phase, where the main focus is on maintenance and reliability of it’s current capabilities.

Later versions of TN SCALE should add better support for sandboxes, which are similar to jails in CORE. As of Dragonfish, only initial support has been added. Hopefully Electric Eel (24.10) will include GUI support that should make the process of deploying these ‘jails’ considerably easier.

CORE’s future is unclear, but it seems very unlikely it’s headed in any direction at all. At best it will be in an extended support status for the foreseeable future, with no plans to add any features at all or do more than fix the most serious of bugs.

But I think it’s also worth noting that all those “do it all” features that you don’t think belong on a NAS, have been in FreeNAS/CORE for a good many years. Not implemented nearly as well, but they were trying. The only thing that was going to be unique to SCALE was clustering, and that’s since gone away. But just like in CORE, you don’t have to use them in SCALE either. Don’t want apps? Simple solution: don’t use them. If you aren’t going to use them, don’t choose an apps pool, and the system doesn’t run at all.


Thanks for the info on CORE, i only mentioned what i read somewhere in replay to the future of CORE in relation to SCALE, but everything is hearsay until it is proven. So we will see.

It is not so much what i am comfortable with as what i can get answers / support / solutions for when i run into a problem and currently most responses i’ve seen (granted i haven’t dug though all the thread here) around CORE is move to SCALE as updates to CORE and CORE “JAILS” will not happen much anymore. So i can in theory run nextcloud on CORE but if it breaks like mine did i’m kinda stuck or if it get’s outdated i’ll be lucky if i get a update when the maintainer decides to update it.

I’m not sure what i did but my nextcloud seems to have fixed itself, but it didn’t update it still shows:
App Version: 29.0.0
Chart Version: 2.0.5
and i still get a notice every time i login it that say’s update is available 29.0.0_2.0.6

The App still shows Deploying but i can login to my nextcloud account so IDK, at this point i’m too scared to try clicking update again.

Appreciate the feedback! The install issues are concerning, would have been nice to investigate those to see what was exactly going wrong in that case.

As for Apps, agreed Nextcloud is a PITA to deploy, no matter which version I’ve played with it has never been that good of an experience for me as well. That said, you may be better off deploying a sandbox for Nextcloud and doing some of it by hand. Key functionality is so highly dependent on customization that go beyond a container, that seems to the only way to properly run it.

There are some CORE absolutists here that you may be able to request help from for sure - for some things (virtualization) I would definitely lean towards saying SCALE is better, but for a stable appliance that you can almost guarantee to run without issues I can absolutely see the benefits of CORE as well.

@kris do you know if a sandbox interface in the WebGUI is in the works for (potentially) 24.10 or later? Am sure there’d be a lot of appreciation for an easy-to-use replcaement to k3s and believe I’ve seen you also vent some frustration towards it recently (though it may have been somoene else :stuck_out_tongue: )

Sandboxes in the GUI don’t seem likely for 24.10. 25.04 at the soonest I suspect and I strongly agree it will need to happen at some point :slight_smile:

Some work happening in 24.10 right now to make Apps suck less in general, we’ll have details on that in the near future.


If the app still says deploying but you are able to log into it, it may just be a browser cache issue. Try doing a ctrl+f5 refresh on the Installed Apps screen

Sorry to “dig up” a old topic but i’m not sure if this might point you in a direction of the issues i had with the install …

I just plugged the 1st flash drive i had issues with back into the TrueNAS server after formatting and re-partitioning it twice on my desktop and TrueNAS somehow still sees it as a boot-pool as the image above shows.

Also the 1st time i cleared all the partitions off it the “1st” partition on the drive had a bunch of random characters as a label didn’t pay much attention to it as i though the drive got corrupted and wanted to re-partition and check if it still accepted data.

The Drive Displays as below in windows after re-partitioning it