TrueNAS Scale 24.04.0 Failed to install Nextcloud

Hi I’m new to Scale.

I want to use Nextcloud.
But now I get the following error when I try to install it.

App Version: 29.0.0
Version 2.0.2

[EFAULT] Failed to install App: WARNING: Kubernetes configuration file is group-readable. This is insecure. Location: /etc/rancher/k3s/k3s.yaml
Error: INSTALLATION FAILED: 1 error occurred:
* Secret in version “v1” cannot be handled as a Secret: json: cannot unmarshal number into Go struct field Secret.stringData of type string

I hope someone has a solution.

I have tested this and Nextcloud deploys using the instructions provided in the TrueNAS Documenation Hub, even though they are a bit outdated for the current UI.

I’ll be pushing updates to the article today.

to set the ffmpeg options, click Add to the right of Command to add the Command field, then click in the field and select ffmpeg.

When setting up storage do not select the Pre v2 Storage Structure) checkbox.
Select the Host Path option for all four datasets.

Select the data dataset for Nextcloud AppData Storage
Select the opt dataset for the user storage
Select the db dataset for the postgres storage
and finally select dbbackup dataset for postgres backup storage.

After clicking Install, the system begins the installation process. After a few minutes the Installed Application screen shows the Nextcloud in the Deploying state. It takes about 10 minutes, maybe longer for the app to fully deploy and switch to Running.

If you get any tracebacks or errors, open a Jira ticket and let us know what the issue is.

I always had problems deploying Nextcloud and eventually settled on a VM.

But I came across Immich and because I only used Nextcloud for image backup I deleted the VM and switched to Immich.

Hello i have this issue when trying to add OVERWRITEHOST variable to enable access to my domain.
[EFAULT] Failed to update App: WARNING: Kubernetes configuration file is group-readable. This is insecure. Location: /etc/rancher/k3s/k3s.yaml Error: UPGRADE FAILED: execution error at (nextcloud/templates/common.yaml:38:4): Container - Environment Variable [OVERWRITEHOST] in [envList] tried to override the Environment Variable that is already defined in [Secret - nextcloud-creds]
More info…
Error: Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/middlewared/”, line 469, in run
await self.future
File “/usr/lib/python3/dist-packages/middlewared/”, line 511, in __run_body
rv = await self.method(*args)
File “/usr/lib/python3/dist-packages/middlewared/service/”, line 210, in nf
rv = await func(*args, **kwargs)
File “/usr/lib/python3/dist-packages/middlewared/schema/”, line 47, in nf
res = await f(*args, **kwargs)
File “/usr/lib/python3/dist-packages/middlewared/schema/”, line 187, in nf
return await func(*args, **kwargs)
File “/usr/lib/python3/dist-packages/middlewared/plugins/chart_releases_linux/”, line 567, in do_update
await‘chart.release.helm_action’, chart_release, chart_path, config, ‘update’)
File “/usr/lib/python3/dist-packages/middlewared/”, line 1564, in call
return await self._call(
File “/usr/lib/python3/dist-packages/middlewared/”, line 1428, in _call
return await self.run_in_executor(prepared_call.executor, methodobj, *prepared_call.args)
File “/usr/lib/python3/dist-packages/middlewared/”, line 1321, in run_in_executor
return await loop.run_in_executor(pool, functools.partial(method, *args, **kwargs))
File “/usr/lib/python3.11/concurrent/futures/”, line 58, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/lib/python3/dist-packages/middlewared/plugins/chart_releases_linux/”, line 49, in helm_action
raise CallError(f’Failed to {tn_action} App: {errmsg}')
middlewared.service_exception.CallError: [EFAULT] Failed to update App: WARNING: Kubernetes configuration file is group-readable. This is insecure. Location: /etc/rancher/k3s/k3s.yaml
Error: UPGRADE FAILED: execution error at (nextcloud/templates/common.yaml:38:4): Container - Environment Variable [OVERWRITEHOST] in [envList] tried to override the Environment Variable that is already defined in [Secret - nextcloud-creds]

Can you help ?

Update. After a review by our developers I updated the documentation again this morning. The four dataset names changed from the original names used in Bluefin timeframe. As soon as the PRs are approved and merged you will see these changes in the SCALE nightly and 24.04 branch documentation.

@duderuud we have documentation on implementing Immich in TrueNAS SCALE as well!

@koutsouk please open a Jira ticket on that traceback. Please also include your system debug file so our devs can dig into the cause of that issue. Please use the private file attachment option sent to you by the system after you open your ticket so your data remains protected. We mark tickets with debugs attached to them as private to protect user data. The private file attachment area allows us to keep tickets publicly viewable.

@bella I run Immich as an app and it runs great so no VM needed

1 Like

I’m having the same issue. Did you find a solution?

I managed to install Nextcloud.
I followed this guide from toutube.

I installed Nextcloud 1.6.29, and updated to the current version one version at a time.
now I’m struggling a bit with the following.
occ db:add-missing-indices
and remote access through cloudflare tunnel

I don’t know if anything changed since i tried installing nextcloud on SCALE the 1st time a few weeks back, but the select host path for all four datasets did not work for me no matter how i set them. The best way i could get nextcloud installed was

nexcloud appdata, etc - left on default ixVolume
nextcloud user data storage - pointed to a host path
postgres data storage - left on default ixVolume
postgress backup - pointed to a host path

Apart from leaving everything on default as soon as i changed either of the ixVolume settings above nextcloud refused to install or it would install but a DB error would pop up if i try and access the WebPortal.

I’m pretty sure the documentations or a post i read just says could take a while, might be worth it to add (10-15min not impossible) cause i’m pretty sure the 1st 2 times i tried to install i messed it up cause i figured the install failed or something after 5 min or so of not being able to access the web portal.

Maybe somewhere in that step add (can take 10-15min to fully deploy) :man_shrugging:t5:

Thanks for updating the article few things as frustrating as reading the developers guide and your install still failing.

Thank you for your suggestions. We don’t know how long this can take to deploy for everyone and using the pre v2 option as I didn’t test that scenario myself, but it can take over 10- 15 minutes. I’ll push another update after we make more changes to our documentation on deploying apps in the coming weeks. Again… THANK YOU for your input! :grinning:

Saying wait till it says Running works BUT i had the issues where my browser cache didn’t reload the “Deploying” state to Running until i logged out of TrueNAS admin web, closed the tab and reloaded it.

Only after that did my nexcloud change to running. I could hit Ctrl+F5 or just F5 till the cows came home it stayed on Deployed even though i could login to nextcloud already, setup a user for myself connected my phone and it already starting to sync.

So a rough Time Guide even if you say 10-15min + is possible will probably save someone from doing something stupid like restart the server while nextcloud is still deploying, removing the “Apps” Dataset and starting over … (i did that more times than i care to admit) till i read on reddit or somewhere, where someone posted that i took his XXmin to deploy, so the next install i got up and left for a hour plus came back as mentioned Apps still showed deploying but i could access the web portal so i figured it worked.

We hate the cache problem!
To get around it, right click on your browser screen, then click Inspect. This opens a side panel. With that panel opened, right click on the browser refresh icon, then click Hard Reset. If it is a browser cache issue this resolves it! It is my go to now for resetting the browser cache. You can then close the inspect side panel.

1 Like