TrueNAS Scale - Auto Expand ZFS Pool Issues

Hello everyone,

I’ve got some auto-expand ZFS pool issues. I had a ZFS pool of 9x 3TB drives. I offlined each drive and resilvered it with a 12TB drive. It was my understanding that once I replaced each drive in the pool, TrueNAS would recognize the new capacity and expand my pool. Unfortunately, this did not happen. Once all my drives were replaced, I tried clicking the “Expand” button by my pool but got the following error:


  1. I’ve resilvered all my drives, and TrueNAS is not recognizing the new capacity.
  2. The EXPAND button gives the following error
  3. When I step into my Pool’s ‘‘MANAGE DEVICES’’ they all appear to be assigned as seen here:
  4. However when I go back to the ‘"STORAGE’’ its telling me one of my drives is not assigned (12TB) the same drive that is in use in the pool:
    Screenshot 2024-06-22 at 15.08.53
    *if I try adding this drive into my ZFS pool it only allows me to add it as a STRIPE (my pool is Z2), it seems like TrueNAS has assigned this drive into my pool and yet not at the same time haha

Its a bit confusing to be honest, any help would be much appricated. Any commands I can run in my SSH?

I’ve ran a ‘‘zpool status’’ command in my SSH, the pool in question is Genesis:

*All seems healthy, all 9 Drives are online and with no errors


Life saver thank you Dan!

Following your ‘’ If you’ve already done a disk replacement’’ Ive ran the following commands:

However the issue still stays and my pool does not expand any ideas what im doing wrong?

What’s the output of lsblk now?

It seems it has fixed most of them, I think the issue might be with TrueNAS still having one of the drives not assigned to the pool while it clearly is in the pool?

It looks like it fixed all of them. Can you try rebooting and see if that helps?

The reboot worked! Apologies for the amature hour, the old reboot of course