TrueNas Scale cannot clone github repos for apps, but can use the internet for everything else

I recently upgraded my TrueNas Core server to Scale and I can’t get it to use the app function whatsoever (I want to run a Jellyfin server).

Whenever it tries to use the default app catalog, it spits out this:
Error: [EFAULT] Failed to clone ‘GitHub - truenas/charts: TrueNAS SCALE Apps Catalogs & Charts’ repository at ‘/mnt/main_storage/ix-applications/catalogs/github_com_truenas_charts_git_master’ destination: Cmd(‘git’) failed due to: exit code(128) cmdline: git clone -v GitHub - truenas/charts: TrueNAS SCALE Apps Catalogs & Charts /mnt/main_storage/ix-applications/catalogs/github_com_truenas_charts_git_master stderr: 'Cloning into ‘/mnt/main_storage/ix-applications/catalogs/github_com_truenas_charts_git_master’… POST git-upload-pack (164 bytes) POST git-upload-pack (gzip 1717 to 889 bytes) error: 6189 bytes of body are still expected fetch-pack: unexpected disconnect while reading sideband packet fatal: early EOF fatal: index-pack failed ’

And whenever you try to add a new catalog, it fails (I can’t find the error right now, can post later if needed).

Has anybody else had this issue, and if so, can anybody fix this? Whenever I try to get a software update or anything by the way, it works totally fine.

Thanks for any help anyone can give,
Mark :slight_smile:

That is is a bit of a mystery for sure. Assume no packet loss or other network disruptions?

Can you try this manually from the CLI?

# git clone

Yep, no packet loss from anything else. Tried cloning it in the shell, worked perfectly and had no issues. I have no idea why it cannot do this for the apps. Should I possibly try a reinstall?

Reinstall is rather extreme. I’d say first do this:

Go into the TrueNAS UI → Apps → Settings → Unset Pool. Then wait a moment and re-load the Apps UI again and select your pool. That will re-init the Apps system fresh.


Worked!! Thanks so much!

1 Like

Glad to hear its now working.
Just a question though, are you running a bridge (i.e br0 interface)?
If so, the Apps service will not start after a boot (or reboot). This is a known problem with Cobia (and Dragonfish).
As @dan wrote above, UNSETing and “Choose Pool” will fix it. Sadly, you need to do this after any reboot.

I wrote a post in the old community forum.

Unsetting the pool scares me too much. :slight_smile:

An alternative solution is to refresh the app catalog in the App section.

It has to be made at every reboot too, unfortunately.

There are also posts on the old forum saying, that it has something to do with a wrong time set in the BIOS.
That never solved the problem for me so I ended up moving the apps to a VM - and i completly removed everything app related from the system.
Jellyfin/plex is easely done in a VM.

I never had a time problem under Windows, as the NTP client overwrites the bios clock.

I think that TrueNAS should do the same too, as bios usually isn’t aware of Time Zone, at least on the Supermicro motherboards.

I never installed a single app, this issue started just at a fresh install + preferences restore.