TrueNAS SCALE installation - no video output after grub

I’m struggling installing TrueNAS SCALE on my new hardware.
After grub menu and selecting “Start TrueNAS SCALE Installation” i get a black screen, and I’m stuck there without any way to move further.
Initially I assumed there was something with the installer bootstrap itself, I tried several ways to work around this issue, and among them:

  • booting from USB stick
  • booting via virtual drive mount via KVM
  • booting via a redirected media hosted on a PC nfs and cifs export in the network

I then tried to understand if there was any kind of issue with the graphics, so i tried

  • using the VGA output
  • using the HDMI output
  • connecting an external GPU in place of the LSI card and try to boot from that

I also tried booting both the installer for TrueNAS 24 and 23, reaching the same result.
In a last attempt, I tried also to understand if there was something wrong with my hardware: I created a new bootable drive with Ubuntu server 24.04, and to my surprise the Ubuntu live booted flawlessly.

I really have no more options, this is also my first install of TrueNAS, so I’m currently out of ideas.

Here’s is my hardware:

    Motherboard ASRock Rack AM5D4ID-2T/BCM
    CPU AMD Ryzen 5 PRO 7645
    RAM 2x32GB Kingston ECC DDR5
    Hard drives 1x1TB Crucial NVME SSD, 3x4TB WD Red  
    Hard disk controller 10GTek LSI 9211-8i

I have the same problem, created the iso with rufus with the added option to boot with older bios checked.
At boot it loaded grub and I have two option. The regular install and one serial (don’t know what that mean). I selected that and it loaded the installer:(. The regular one doesn’t work, just black screen.

My system spec
Tyan s2895 with the latest bios
Dual opteron 270 cpu
6 gig ecc memory
Supermicro 847 chassis

Did you mean the (115200 baud) one?

Haven’t tried that, I’ll give it a try.

Yes. Hope it helps. There are also some people using ventoy and have luck getting it to work

Nope, still no luck.

Everything I read about black screen on grub seems to point to graphics compatibility and kms modeset. I still have to grow confident enough to fiddle more with those settings in grub.cfg.

My quest is still going.

Edit: also, I’m sure my USB stick works because I create it with dd on Linux, I tried booting it on the some laptop and I get video output after grub menu.

I get a different problem, can’t read weird white lines while trying to install.
Either choices, same result.
Could someone add a safe video option in the grub loader please

I just try ventoy, it works! I can select both options to install truenas scale/core. No black screen.

1 Like

Ok, I solved the issue, and as always it was due to user error.

Basically by reading documentation online I came to understand that AMD Integrated Radeon Graphics works by reserving a memory buffer in RAM. Such buffer cannot be allocated by the OS and is reserved to serve the CPU graphic workloads.

I then looked at the memory details in the BIOS and noticed that by mistake I added my two DIMMS slots to A2+B2 slots, while the recommended occupation for a two-DIMM system is A1+B1.

Even if it seems irrelevant during installation of any other OS different than TrueNAS (in the course of this issue I tried installing both Ubuntu 20.04 and RHEL 9), it seems to mean quite a lot to TrueNAS.
Switching to a A1+B1 configuration magically made the text installer process popup after grub without the need of any other tweak, and now I’m ready to spin my new NAS hardware.

Thank you to everyone tried to give me any additional pointer of suggestion, I now have to understand how to mark this thread as solved.

1 Like