TrueNAS Scale seems to be creating random datasets

Software developer, but new to TrueNAS.

TrueNAS-SCALE-23.10.2 installed in a virtual system under XCP-ng 8.3 beta (Xen). 2 CPU cores, 16 GiB memory, 16GiB boot disk, 1.5 TiB data disk approximately. There’s a couple of other virtual systems doing their thing without issue.

The end goal is to setup a private SMB share for each of four users, and one share that all four users have access to for exchanging information.

I created users, created a pool, then created one dataset for each user under the pool, and one dataset for the shared share, then created an smb share under each dataset.

For some odd reason, when I start adding test folders and files from Windows File Explorer (windows 10) for my share, extra datasets with my name show up under the other user’s datasets (which shouldn’t happen since I don’t have permission to access their smb shares). These are viewable on the Datasets page of the TrueNAS web gui.

Because I couldn’t seemingly undo these changes, at one point I reverted back to defaults using the text console menu and started from scratch. Everything looks fine and then the extra datasets show up again.

It looks like it is sharing the datasets as shares.

If I get into the shell (no I’m not changing things at this level), I see a folder for the pool, and folders for each dataset, but no folders for smb shares. The extra datasets are showing up as folders.

The main reason I wanted to use datasets is so I could set quotas.

I think I’m doing something wrong, just not sure what. Checking a wrong box? Not understanding relationship between datasets and SMB shares?


First of all, Welcome to the TrueNAS Community!

Reading through this, it does sound like something with the shares configuration is off. You are doing the right thing in creating a dataset per-share, so you can get quotas and whatnot. But in this case I’m guessing perhaps the SMB share configuration is wrong? Can you post some screenshots of what those SMB configurations look like so we can see what datasets they point at?

Hey @blackholenulled - do you by any chance have the “Use as Home Share” option checked for any or all of these shares?

1 Like

No, I didn’t check ‘Use as Home Share’ box for any of the users. Should I have?

What is checked:
Enable ACL
Browsable to Network Clients
Enable Shadow Copies
Enable Alternate Data Streams
Enable SMB2/3 Durable Handles

Hmm, the other users have Purpose:Private SMB Datasets and Shares selected, but mine and the shared share says Purpose: Default share parameters, which seems to gray out the ‘Other Options’.

I’m working on the screen shots.


The option to create private SMB datasets automatically creates ZFS datasets with the user’s name by design.