TrueNAS Scale - Virtual IP Address

Hello all! I’m a noob when it comes to TrueNAS, I started on Core but recently switched to Scale and I’ve run into a few issues while migrating.

TrueNAS Scale is currently running on a prebuilt SuperMicro Server (Supermicro AS-3015A-I Mini-Tower Server) after I got Scale up and running the IP Address that TrueNAS Scale was given (as far as I can tell) is a Virtual IP Address.


I tried putting the IP Address into my web browser as normal but I am unable to reach the web interface and I wanted to see if any of you fine folks would be able to help a noob like myself figure this out.

Server Specs:

  • CPU: AMD Ryzen 9 7950X (4.5GHz)
  • GPU: Integrated AMD Radeon Graphics
  • Ram: 16GB DDR5-4800 RAM
  • Boot Drive: 1TB M.2 SSD
  • Motherboard: Supermicro H13SAE-MF

This just happened after the change to SCALE ?
You had access to the WebGUI on CORE ?
You didnt change anything else, and the console is now telling you “The Webinterface is running on” ?

What version of SCALE ?
You didnt by mistake plug in the network cable into the IPMI port ?

I am running a new server, there are a bunch of settings that are different within the BIOs on this new server, I would assume that is because this computer that I’m running TrueNAS on is more like an actual server rather than a typical personal computer.

I am running version 24.04.0. The server does have IPMI, when I boot the computer up I can log into a web interface for the computer itself, it allows me to do things like remote access the server, etc.

There are 3 Ethernet ports on the back of the server, I used the bottom most port and they all seem to work in the same way.

Edit: I also tried accessing the TrueNAS WebUI through truenas.local and that isn’t working either. Yes, I did have access on TrueNAS Core, but again that was on a completely different PC.

On the truenas console, you can choose an option to configure network devices.

You can access that and switch one network interface ( the one with the cable plugged in ) to DHCP.

Fun and interesting.

Addresses in the subnet are what is assigned when an interface is configured for DHCP, but something goes wrong during the IP solicitation phase. These are called link-local or APIPA addresses.

You haven’t mentioned what you’re connecting the ethernet interface to. Is it being directly connected to another machine (which would make a lot of sense in this case)?

I’d definitely check your configuration as @Farout mentioned, if we can get a screenshot of the interfaces page we might be able to sanity-check the config there.

1 Like

Sorry for the poor quality, below is a screenshot of the network interface settings.

The ethernet cable is directly connected to my Router, I have other things plugged into the router (PS4, TV) and they are both seemingly working just fine.

The enx interface is a virtual interface on Supermicro boards used for communication between the OS and the BMC. This can be configured in configuration → BMC settings. It’s used to provide updates via in-OS utilities (i.e. Supermicro Update Manager). Source.

You mentioned there are three ports but I can only see two there (eno1, eno2). Neither of them have picked up a link-local address so it’s probably that they aren’t connected. Try switching ports and confirming that DHCP is enabled on both of those interfaces.

1 Like

Of the three ports:
The bottom port is the IPMI port.
The two ports above the bottom one are regular ethernet ports. You need to plug into one of those in order for Truenas to connect.


Thank you @PhilD13 & @essinghigh, I switched the ethernet cable to the top most port and this thing is running like a dream! I owe you guys one!!

Thank you so much for dealing with my noob skills in this area! :smiley:

1 Like