TrueNAS SMB Share not working on Win11 but on MacOS

Hello all,

This is pulling my hair out. I recently moved and setup my TrueNAS Core rig on my Unifi UDM with an SFP for 10gbe.

The macbook i have can open the SMB share no problem and I can access the data over wifi. The two windows desktops on one Wifi one on Ethernet give me an “the folder you entered does not appear to be valid”

I can login into my TrueNAS from the local IP on any computer… I have googled the issue and done various things with the windows registry, I have turned netbios id on, made sure the workgroup is correct, etc Nothing seems to work… I have ACL permissions with a non-root user I created setup, that’s been assigned to the the filesystem.

Any help would be greatly appreciated

Please post output of testparm -s command from shell.

Here ya go,


root@MarkNAS[~]# testparm -s
Load smb config files from /usr/local/etc/smb4.conf
lpcfg_do_global_parameter: WARNING: The "client ntlmv2 auth" option is deprecated
Loaded services file OK.
Weak crypto is allowed

Server role: ROLE_STANDALONE

# Global parameters
[global]
        aio max threads = 2
        bind interfaces only = Yes
        client NTLMv2 auth = No
        disable spoolss = Yes
        dns proxy = No
        enable web service discovery = Yes
        kernel change notify = No
        load printers = No
        logging = file
        map to guest = Bad User
        max log size = 5120
        netbios name = TRUENAS
        nsupdate command = /usr/local/bin/samba-nsupdate -g
        ntlm auth = ntlmv1-permitted
        registry shares = Yes
        server min protocol = NT1
        server multi channel support = No
        server role = standalone server
        server string = TrueNAS Server
        idmap config *: range = 90000001-100000000
        rpc_server:mdssvc = disabled
        rpc_daemon:mdssd = disabled
        idmap config * : backend = tdb
        directory name cache size = 0
        dos filemode = Yes


[Vault ]
        ea support = No
        guest ok = Yes
        kernel share modes = No
        path = /mnt/The Vault/Vault
        posix locking = No
        read only = No
        smbd max xattr size = 2097152
        vfs objects = streams_xattr shadow_copy_zfs ixnas zfs_core aio_fbsd
        nfs4:chown = true
	 ixnas:dosattrib_xattr = false

Do you have any SMB auth log entries correlating with the auth attempts by Windows?

midclt call smb.status AUTH_LOG | jq

I just tired again on the windows computer here’s what I get


  {
    "timestamp": "2024-06-17T19:28:41.484124-0700",
    "type": "Authentication",
    "Authentication": {
      "version": {
        "major": 1,
        "minor": 2
      },
      "eventId": 4624,
      "logonId": "0",
      "logonType": 3,
      "status": "NT_STATUS_OK",
      "localAddress": "ipv4:192.168.1.199:445",
      "remoteAddress": "ipv4:192.168.1.120:54696",
      "serviceDescription": "SMB2",
      "authDescription": null,
      "clientDomain": "MicrosoftAccount",
      "clientAccount": "Mk32",
      "workstation": "MARK-DESKTOP",
      "becameAccount": "Mk32",
      "becameDomain": "TRUENAS",
      "becameSid": "S-1-5-21-113321727-37780821-90607280-20035",
      "mappedAccount": "Mk32",
      "mappedDomain": "MicrosoftAccount",
      "netlogonComputer": null,
      "netlogonTrustAccount": null,
      "netlogonNegotiateFlags": "0x00000000",
      "netlogonSecureChannelType": 0,
      "netlogonTrustAccountSid": null,
      "passwordType": "NTLMv2",
      "duration": 1865
    },
    "timestamp_tval": {
      "tv_sec": 1718677721,
      "tv_usec": 484124
    }
  }

And on the windows computer I get this error
image

You’ve enabled guest access on the share and windows security settings are rejecting it. The general rule of thumb with modern OSes is to not use guest access. It’s not that difficult to create a user account in the GUI.

Create a user account, disable guest access to the share, and then go about your business. :slight_smile:

1 Like

Good catch, so I did that restarted

And an using a user I created:

image

And still get the same error :frowning:

And here’s the log with the guest access turned off


  {
    "timestamp": "2024-06-18T10:13:07.139229-0700",
    "type": "Authentication",
    "Authentication": {
      "version": {
        "major": 1,
        "minor": 2
      },
      "eventId": 4624,
      "logonId": "0",
      "logonType": 3,
      "status": "NT_STATUS_OK",
      "localAddress": "ipv4:192.168.1.199:445",
      "remoteAddress": "ipv4:192.168.1.120:63043",
      "serviceDescription": "SMB2",
      "authDescription": null,
      "clientDomain": "MicrosoftAccount",
      "clientAccount": "Mk32",
      "workstation": "MARK-DESKTOP",
      "becameAccount": "Mk32",
      "becameDomain": "TRUENAS",
      "becameSid": "S-1-5-21-113321727-37780821-90607280-20035",
      "mappedAccount": "Mk32",
      "mappedDomain": "MicrosoftAccount",
      "netlogonComputer": null,
      "netlogonTrustAccount": null,
      "netlogonNegotiateFlags": "0x00000000",
      "netlogonSecureChannelType": 0,
      "netlogonTrustAccountSid": null,
      "passwordType": "NTLMv2",
      "duration": 1680
    },
    "timestamp_tval": {
      "tv_sec": 1718730787,
      "tv_usec": 139229
    }
  }
]


Also super thanks for helping out

Welp I acutally got it working but I don’t know what happened.

You can see I was sharing “Vault” before but I created a new share sharing the filesystem up and I see the folder has a new folder name? And that was the cause of my problems…