Truenas stuck on GNU Screen / Wont Boot

Hi there

I am a relatively NOOB when it comes to TrueNAS, I have 5 TrueNas Servers.

One of them is now acting up, it looks like after an update or something it will not boot (go past the GNU screen, no matter what option I choose) - even TrueNas CORE same error…

Linux 5.15.107+truenas
error: checksum verification failed
Loading initial ramdisk ...
error: you need to load the kernel first

I am in panic mode, I can reload an earlier version, but I cannot lose the data on the drives, there are around 7TB of crucial data of a customer on that pool.

So here are the currently installed version details…

TrueNas Scale
TrueNas Core

I have 5 x 4TB ST4000 SATA DRIVES and 1 x 256GB SanDIsk (This is where Truenas is installed any of the other drives tell me they are Truenas Drives and System halted)

  1. If I have to reload TrueNas - what version?
  2. How do I reimport the disks and the zPool without losing the data? I did this server around 4 years ago…
  3. ANY help will be appreciated. If there is anything else I can must add please let me know and will do so

The nice thing about truenas is that the boot drive is fully replacable without any dataloss. You can just install truenas on a new ssd, upload the config file you hopefully have backed up, and you’re back.
You can either install truenas scale 23.10 or core 13.1-U6. both versions should support your existing pools

If you dont have a config backup saved, you’d have to manually recreate your config, users and shares and permissions, but after that everything should work again

Hi there

upload the config file you hopefully have backed up

Don’t think I have that? Is that a big issue?

Assuming your configuration isn’t a huge PITA to redo then no. You’d have to start fresh from a configuration perspective but the data on your pools will remain intact. This would be a good learning experience on taking config backups before/after any large configuration change.

Did you upgrade the boot pool by chance?

I will reload on a new 256GB SSD now, once up can some help me please that I don’t f**up once done on re-importing the pool / re-creating the pool etc…

Thanks a million!

You don’t have to re-create the pool you just have to import it using the gui. There should be a drop-down menu where cho can choose which pool you want to import, then you simply click import and done.

Thank you… yeah will have to back that up, I just don’t want to mess the whole file system once done, the share I can re-create there is only one as long as all the data is there…

But i don’t want to mess up the “new install” as well…


for automatic config backups and status reports i’d recommend the Multi-Report-Script from our fellow forum member joeschmuck. It can send status reports for drives etc and includes a config backup via e-mail


If I had to guess, you or someone else probably ran zpool upgrade -a or zpool upgrade boot-pool at some point. What you are seeing looks very similar to what I’d expect to see.

See: FWIW: When it says "Don't upgrade the boot pool", they are not kidding! | TrueNAS Community

Unless you play around with the CLI it’s surprisingly difficult to break anything, as long as you keep config backups, it also doesn’t matter if something breaks as you can just restore!

1 Like

As long as it’s not encrypted….


Hadn’t though about that, let’s hope! :smiley:

1 Like

Thank you guys! All up and running

I am going to leave it on TrueNAS-13.0-U6.1 CORE not going to update to anything else.

Some questions though…

  1. How can I backup the entire TrueNas to ie. OneDrive or a Cloud SP or do I have to upgrade to TrueNas-SCALE-xxx then to do this?
  2. How do I backup the config?
  3. I have SNAPSHOTS, can I delete these? They are from 2023 and lastly how do I re-setup the SNAPSHOTS… Once a month or so…

I almost had a heart attack, at least it worked out, but next time I might not be so lucky.

I know SCALE has this capability. Data Protection → Cloud Sync Tasks.
Unfortunately I have little to no experience with CORE so couldn’t say.

Again, SCALE instructions, though I think this is the same on CORE.
System Settings → General → Manage Configuration → Download File

There is also @joeschmuck’s excellent Multi-Report script linked above that can automate this along with various other excellent status reports.

Here’s an excellent basic primer on snapshots from @winnielinnie . Whether or not you want to delete them is up to you. I have a daily scheduled snapshot task and I store them for two weeks.

Thanks it worked! All done

1 Like