`Type*` dropdown fields for `Plex Data Storage`, and `Plex Configuration Storage`, are disabled, and I'm not sure what I need to do to enable them

Hello everyone, I’m happy to be here and glad to have a place to ask for help!

  • I have a TrueNAS Scale machine that I’m trying to get set up with Plex, but I can’t seem to get Plex to share the directory where my media files will be stored

  • The problem is that the Type* dropdown fields for Plex Data Storage, and Plex Configuration Storage, are disabled, and I’m not sure what I need to do to enable them

  • The vast majority of instructions I’ve found online dealing with this appear to be using an older version of both TrueNAS and Plex, so none of the settings or directions seem to apply to my situation

  • Here is a link to a gist that explains my situation in more detail

  • This is my first post here, so if I’ve made any mistakes, or posted this to the wrong place, please let me know

  • I’ve tried my best to do my due diligence to solve this issue myself, but I’ve failed at every turn.

  • Any help is greatly appreciated, and if you need any other information I’ve neglected to include, please let me know and I’ll respond/update the gist post haste.

I’m guessing you’re trying to modify those fields on an existing installation? If so, I believe those are disabled by design. You can recreate the plex app with the correct storage configuration and Type should be selectable from the Install screen.

1 Like

First of all, thank you so much for taking the time to read my case and respond, I am verily grateful (I wish the words “great” and “grateful” had a consistent vowel structure)

I don’t believe I understand what you mean by “an existing installation”. I installed Plex via the Discover option from the Apps menu in the TrueNAS web interface. Could you explain, please?

@DjP-iX means, that you cannot change these parameters after you installed the app. You have to do this during the installation.

1 Like

Thank you!

I apologize for my apparent ignorance, but what exactly do I need to do to my current configuration to, as @DjP-iX has suggested, “recreate the plex app with the correct storage configuration”.

I’ve tried to follow different instructions online for this setup but they are all using an older version of TrueNAS Scale and the settings structure/names/options appear vastly different than in the current version.