Unable to access a share in TrueNAS Scale


I tried to follow multiple tutorials to create a share with TrueNAS Scale. My goal is to have a dataset that would allow me to automatically backup files to it and one that would host a Minecraft server with MineOS.

1- Is this the right thing to do?
2- If yes, why am I getting denied permission if I put myself in a group that has access to the share? Do I need to port forward my NAS? I really don’t understand anything.

Here is the error message I get (it’s in French):


please share your version of truenas, your ACL setup and your share settings.

Nobody can work out what went wrong from the error message alone.

TrueNAS version : Dragonfish-
Share settings:

ACL setup:

Here are my user settings in case you need them:

(Samba is enabled below)

I hope this can help!

Do you really want / need to modify both the SMB ACL and filesystem ACL?

Personally I just leave the allow everyone in the SMB settings (you also still have it there, I’m not sure adding the group there adds any benefit) and just modify the filesystem ACL.

Dragonfish made creating shares easier, I would need to check the documentation myself for the other workflow.

I don’t see any obvious mistakes here, can you retry the filesystem ACL and check “apply recursively” please?

I tried, but it really does not work. I cannot understand why. Do I have to do something in my router settings?
I tried reinstalling, creating a new share with new user and giving me permissions to that share, but it still does not work.