Unable to change time/timezone

So I have changed my timezone to the correct one, and was hoping that it would change the time for my nas. This was not the case it still says that it is 12 pm when I check the date in the console. I have changed my time in the bois to match the current real time, and have tried rebooting multiple times to see if it was stuck.I even went into terminal and tried setting the date manually but it said that it was invalid. I am currently at a loss if anyone has any pointers

The BIOS time should match the current real tim in UTC. Not in your local time. If you’re off by 5 hours (as you would be if it’s set to local time), NTP won’t sync.

You changed your --time-- or your --timezone-- in the BIOS ?

I changed the time not the timezone in bois. I went back into bois to check for a timezone to see if I had missed something and there was nothing there

The BIOS should have an option to adjust the timezone. I suspect this is the root cause of your problem. Your BIOS in in UTC and must be switched to your local zone.

I looked for a second time and there was no UTC setting that could be changed to local. the only thing time related is the clock that you adjust manually.

I’ve never, in 30+ years of working on PCs, seen an option in the BIOS for time zone. The time needs to be set to current UTC. That’s it.

So did you set it to local time, or to UTC? If the former, that’s your problem. Set it to UTC.

1 Like

I have set it to the correct time of central UTC. As long as the seconds aren’t a big factor everything should be working with that.

There’s no such thing as “central UTC.” Is it set to central, or to UTC?

Just to be perfectly unambiguous: right now, your BIOS clock should be set to 8 Apr 24 at 01:36. That’s the current time in UTC.


I changed my clock to UTC and was then able to confirm that the truenas clock was correct.