Unable to create a Pool

I had a ZFS pool of mirrored 6tb drives running on proxmox, i wiped this ZFS.

Now I passed-through those 2 drives into a truenas scale VM, trying to create a pool but I’m getting this error " Error: one or more vdevs refer to the same device, or one of
the devices is part of an active md or lvm device ". anyway how can i fully remove the data in those drive from the old ZFS pool in proxmxo? I tried different way to remove leftover from the old ZFS but non of the worked.

Thanks in advance

Bad plan. The only safe way to virtualize TrueNAS is to pass through the whole controller, not individual disks.

But with that said, assuming you’re 100% sure those disks aren’t in use by anything else, a pass or two of badblocks will, in addition to testing the disks, erase any data that might be there.

2 Likes

sorry for my lack of info, i passed-through them one by one since i have only 2 sata on the MB, not a controller. (assuming that what u mean?).

Also, what do you mean by this ? I still didn’t get it :confused:

Badblocks is a test program that in addition to test the disc, will erase all content. It might be slow = days.

You have a onboard SATA controller. You should pass that to Truenas and your connected discs will be passed through aswell. But that means that you need to install proxmox on a disc that is not on that controller, for example a NVME drive.

Edit: That beeing said, you might be better off with OMV in a proxmox container for filesharing with your hardware.

1 Like

Thanks :grinning:

I will backup up my VMs/LXCs, and reinstall proxmox on an M.2 drive, and pass-through the entire onboard sata controller after. Hope this will fix the error. if not, I will reply here either way.

Thanks again.

1 Like