Unable to log on to interface

Good days truenazers,
I have been using the truenas system a bit from an old desktop and it has been performing as it should.

I have gradually added devices such as 6port pci sata card to the stock setup.
I mainly use this to back my phone, and camera pics and also im using the plex nas plugin that really works well on the tv!

Recently i realized my transfer speeds were pretty slow 1 to 6mbs from my pc to the nas. I eventually added an intel X540-t2. I thought it would have been plug an play but it was not.
I have disabled the onboard nic and still no connectivity. On the console setup screen i select 1) configure network interfaces , i play around a bit and set up the ipv4 to the ip i previously had. - Only then i can connect to the web interface! i thought my issues were over, over night the ip seems to get lost and i lose access to the ip i initially set. ( this never happened to the onboard)

I have tried option 8 ) REset al configs to default ( i had ot reconfigure the ip again ,logged in and shat my pants when i saw no pools!!! I have since then recovered the pools) The connection was great till the next day when i tried access the NAS it says the site cant be reached.

When the connection works, it really works well 100+mbs transfer speeds. However its very finicky and unrealiable. Can anyone advise what i can check or troubleshoot?

My rig is a basic dell 7010
i3 -3240 cpu
16gb ram
2 ssd for boot
4 x6tb wd red plus
4x1tb seagate
intel x540 nic
6 port sata pci card

NB - i just tried connecting to the web interface and i had to remove the ip and add another ip to be able to access it! help

Is this a verifiable genuine Intel product? Not counterfeit?

With that said, there are reputable resellers that will sell you a previously loved (used) NIC and offer you a decent return policy.

If you pull the card, take some photos of both sides, post those here, someone may be able to quickly tell you if they suspect a counterfeit card.

Should have a yottamark/bradyid sticker on it you can use to verify no? I believe mine does. If it doesn’t it could still be real, maybe someone removed it (for some reason…)

Also, just as a note I’ve been using an X540-T2 for quite a while now and have not had a single stability issue. I’d also be scrutinizing the NIC if it works using the onboard one.

@essinghigh Love the name of your system !


The nic doesnt have the yotamark sticker on it. I bought it off ebay as used

I initially thought it was the NIC but on removal and defaulting to the onboard i seem to have the same issue. (Not sure if the network settings got messed up and id need to reconfigure once the onboard nic is enabled once more)

Maybe it is a counterfeit- anyway to check if truenas sees it as counterfeit or genuine?

The picture in the listing looks legit, it’s entirely possible Intel weren’t using Yottamark in 2012. Both of mine were manufactured in 2014.

That would point it more towards a config issue as you mention. Can we take a look at your network config?

It’s exactly as it says on the tin, and I wouldn’t have it any other way! (Accidentally DOS’d myself yesterday running an increasing number of looping failed calls to middleware’s API, also heating up my house a couple of degrees in the process, so it really does live up to its name)

1 Like

@Rajiv Is this the actual photo of the card you have? Not just the add off of EBay? does it make a difference? It sure does if you suspect foul play.

I hope your card is good and it is just a configuration issue.

1 Like

This is the actual card i got (identical to that which was on the listing), there was the intel logo printed on the card (not a sticker) .
I want to believe its legit since i am getting the speeds when im actually able to connect!

Im a basic user and new to most things, can you advise what exactly can i display to you kind folks?

Are you trying to connect at 10Gbps or something else?

Have you tried another PCIe slot, if you have one that is.

In the BIOS, did you disable the onboard NIC? You should do this as it can lead to issues. I know you said that earlier, just making sure.

Have you tried a different CAT6e cable?

Also, what is on the other end that you are connected to?

My onboad nic was a 10/100 so i was only looking to improve transfer speed copying files from my computer to the nas.

I have tried 2 pcie slots, currently utilizing the one i had my gpu on ( using onboard video for now)

Onboard NIC is disabled in the bios

I have tried other cat5e cables with same issue

A tplink gigabit switch sits between my isp modem/router and the nas.
Most of my devices connect to the switch (Nas, computer transfering files)

Just so I’m clear… All of your networking traffic goes from end to end via the network switch. No wireless is being used for the testing, no internet testing either.

If that is true, I recommend you connect a computer directly to the NAS, nothing in the middle. If that solves the speed problem then you have a different networking issue.

All my devices are behind the switch. The issue isnt speed , its the web interface continuously losing connectivity unless i reset the network config and either use a different ip or otherwise. I initially swapped to tine intel nic as i was suffering slow transfer speed- not an issue anymore once i am able to connect to the nas. Once i can connect- wireless and LAN transfer work as it should without issues.

Sorry, I didn’t realize that was the issue.

Is TrueNAS running on bare metal, not in a VM like I do on ESXi?

Stupid question, are you using DHCP or a Static IP address. If DHCP, that could be the problem. but it can’t be that simple :face_with_raised_eyebrow:

So i seem to have the netowrk issue undercontrol. The issue was the nic had 2 ips (dual port card) . I have disabled one interface completely and readded the new card mac to the static address on my router. So far it seems to be stable. (the mac via shell was different than that on the interface- i used the interface mac)


Glad you got it figured out.