Unable to publish rtsp stream from virtualmachine, connection refused

so i have been using this command

ffmpeg -f v4l2 -input_format yuyv422 -i /dev/video0 -f alsa -i plughw:CARD=HD,DEV=0 -c:v libx264 -preset fast -tune zerolatency -c:a aac -b:a 128k -strict experimental -vf "format=yuv420p" -f rtsp rtsp://localhost:8554/cam

to stream a rtsp stream from a usb webcam, webcan is visible with usb passtrhough, but i am uanble to publish it, i get this error

[in#1/alsa @ 0x63aff5c3fe80] Thread message queue blocking; consider raising the thread_queue_size option (current value: 8)
[tcp @ 0x63aff5eb0380] Connection to tcp://localhost:8554?timeout=0 failed: Connection refused
[out#0/rtsp @ 0x63aff5c40bc0] Could not write header (incorrect codec parameters ?): Connection refused
Error while filtering: Connection refused
[out#0/rtsp @ 0x63aff5c40bc0] Nothing was written into output file, because at least one of its streams received no packets.

is it not possible from virtualmachine? how can i make it work, i tried using different network adapter didnt work different distros didnt work

no idea? is there some network setting that dissallows virtualmachines publishing to localhost? i could export somehow that VM so you can test it out but i have no idea how to do it in truenas

still no answer? where else can i get some support

maybe https://www.reddit.com/r/ffmpeg/