Unable to read squashfs_super_block


My less than a month old server installed fine, updated from 24.04 to 24.04.1 fine. Today when I tried to deal with the latest update I got a load of errors about being unable to connect to Truenas’s servers. Being the good nerd I am I initially blamed DNS, but had to rule that out. I then blamed IPv6 routing, and ruled that out. So I connected to the console and saw a load of errors about squashfs.

And when I clicked check for updates instantly get the below error:

I’ve searched this forum and can’t find this error message. What do I do?

It’s installed on normal hard drives, not USBs.

Decided to pull the boot drive, pop in a new drive, re-install and restore config, and it’s back up and running and no squashfs errors, so I guess something on the boot drive got corrupted? I’ve got the debug logs if they are of any use.

But I still can’t connect to the TrueNas servers, despite internet working fine, I’ve disabled IPv6 just in case it’s a bad IPv6 route (it happens a bit), and even changed DNS servers for the NAS just in case… Same result.

So I’m guessing that routing to TrueNas’s servers from Australialand is currently stuffed, and that co-incidentally also triggered me seeing the squashfs errors and they are two separate issues.