Upgraded to TrueNAS-SCALE-24.04.1 and now the web UI doesn't start

Hi,
I upgraded to TrueNAS-SCALE-24.04.1 from TrueNAS-SCALE-24.04.0 and now the webUI doesn’t start. Where can I start debugging this on the command line?
Thanks,
Ry

Have you cleared your browser cache / tried another browser?
Cache is the mortal enemy of the TrueNAS WebUI

the issue is the webserver is not running (connection refused).

Can you confirm nginx and middlewared are running?

systemctl status middlewared
systemctl status nginx
lsof -Pi | grep -P ":(443|80) \(LISTEN\)"

OK, I figured it out.

The issue was the default certificate expired at the same time.

Replacing the certificate for the UI fixed it.

I was able to connect on http to fix it.

Thank you all!

Anything that can go wrong will go wrong, and at the worst possible time.