UPS - NUT Server Issues - Dragonfish

Is anybody having issues with the UPS NUT service on TrueNAS SCALE Dragonfish 24.04.0?

I am getting the same problem again as originally reported when i upgraded to COBIA, see here.

The errors are the same when running
upsc ups
Init SSL without certificate database
Error: Driver not connected

Some of the suggestions were granting the nut user owner rights to /run/nut/* location or running command

sudo upsdrvctl start

But it’s still not working and i can’t remember what exactly i did to resolve prior to the fix on COBIA.

Some other output i get

Network UPS Tools upsd 2.8.0
fopen /run/nut/ No such file or directory
Could not find PID file ‘/run/nut/’ to see if previous upsd instance is already running!

not listening on ::1 port 3493
not listening on port 3493
no listening interface available

dmesg | grep CP9
[ 2.247477] usb 2-1.6: Product: CP900EPFCLCD
[ 2.445525] hid-generic 0003:0764:0501.0003: hiddev0,hidraw2: USB HID v1.10 Device [CPS CP900EPFCLCD] on usb-0000:00:1a.0-1.6/input0

I have checked my UPS service settings through the GUI and they are exactly the same as when i was on COBIA without this issue. I tried tweaking some settings to no avail.

Also tried restarting the service but no luck. I have noticed that the nut-server file is looking for a file in /run/nut but the file never gets created.

/etc/init.d/nut-server restart

Any assistance would be much appreciated.