User activity multiple sessions are active for the current user

I just installed TrueCommand on Docker running locally and in the process of setting it up. I keep getting warnings saying:

User activity
Multiple sessions are active for the current user. 17 sessions detected.

Starts at 2 and continues to showup starting at “2 sessions detected” and after a few minutes it’s up to 17 sessions detected now and still going up.

Not sure what’s causing this, It’s a fresh install. I created my user, setup smtp and in process of connecting my TrueNas scale servers. I’ve done a quick search but havn’t found any conversations of anyone else experiencing this. Lastnight I tried to install in TrueNAS Scale before deciding to switch to hosting on a seperate docker system but I seen this when it was installed on one of my TrueNAS Scale servers.

Any recomendations of what I can do to fix this?

@SHoover80 what version of TrueCommand are you running?

3.0.2 I presume. It’s ixsystems/truecommand:latest docker that I’m running currently. When I initially posted this I had just setup in truenas scale and experienced the same issue. Figured I’d try hosting it from my docker system instead to see if I’d have the same issue. And I am still experiencing this same issue.

It’s all out of the box setup using basic config. I tried running this about a year ago but had issues with True Command staying connected to my TrueNas Scale machines. I’d always have one that would loose connection and I had to delete and re-add that machine but within an hour it would loose connection again. I’m no longer getting that issue but experiencing this issue with the repeated notifications claiming multiple sessions are occurring.

That and getting spammed once I setup email notification every couple minutes informing me that my storage pool is over 85%. As if that’s something by default it needs to spam you multiple emails every 3 minutes to inform me.


I only setup the email notification server settings and where to send notification emails to. I made no other changes. and the next day I wake up to over 200 email repetetive email notifications about non critical things. By repetetive, I mean the same email with the same information that by default should only be sent out at max once per day. Not over 200 times in a 6 hour period. I had to shut TrueCommand down to stop the emails and they were still flooding in for over an hour after I shut it down. I havn’t found any settings to adjust the frequency and alert type to be notified of. I found the alert rules, and had to pause the ones pertaining to storage pool as they had no option to edit.

@Scott_Collins
I lied, It’s every 2 minutes I get 2 of the same email notifying me about storage space.


I had these alerts paused but apparantly it doesn’t persist past restart. What is the point of spamming my damn mail with notification and no means to set the frequency or stop the alerts that persist past restart. This program is shit. I waited a year to see if it’s improved any. I see it hasn’t. I installed the software, setup credentials, linked my servers, and setup email notification. Should be pretty basic but instead I’m hassled with day after day of troubleshooting, researching, time wasted attempting to get this software to do what it’s intended to do. apparantly that’s asking too much. I’ve tried hosting in two seperate environments just to experience the same issues. This software is entirely too problamatic.

Thank you for your feedback. There’s a bug in 3.0.1 where migrated users lose alert permissions. This is fixed in the nightly on the gcr.io repo. However, it appears you do not have this issue and are able to pause the alert. The philosophy of alerting is to let you know as soon as possible, where the alert can be dismissed through TC and ergo the NAS. For this alert, since it originates from TC, you’d need to pause it. You can’t edit these default alerts, but you could create a new one using Pool Total Usage to supply your own percentage. Configurable alert intervals and email limit would be useful features for these cases. Pausing the alert should persist past restart. That would appear to be a bug on its own.

We don’t recommend hosting TC on a TrueNAS directly, but others do and if it works the same or better than another docker host then that’s fine. I’m not sure about the multiple sessions, I think that’s coming from stale tokens not being re-utilized but the UI creating new ones. We reworked the auth layer in 3.0 with configurable timeouts, but there’s a bug somewhere with the token storage. I’ve encountered that as well locally.

For what it’s worth, the Docker Hub image is a slightly different build than the gcr.io image, with the latter also having a nightly in the form of latest, 3.0.2, as opposed to the Docker Hub’s latest, which is only the last public release, 3.0.1. I created a couple of tickets for these issues (pausing default alerts not persisting, stale tokens showing up as active users).

A single alert notification as soon as possible is great, for critical Alerts. Two emails every two minutes for the same alert is extremely over excessive for a non critical concerns, useless as it provides no additional benifit to being spammed with the same email. However it does provide unnecessary waste of time having to go through and delete houndreds of repetative emails in a couple hour time span that no one is going to take the time to read. And unnecessary network/hardware resource usage. Even for Critical alerts 2 emails every two minutes is over excessive. perhaps if the server was on fire maybe. But other than that it’s extremely over excessive. There is no need to have more than one email a day. Maybe one email an hour for absolutely critical things if the server was deployed for business purposes. But even then I’d imagine anyone managing the IT would not want to be constantly spammed with alerts and end up ignoring them. There should be a option to adjust the frequency of all alert notifications, Custom or default and the alerts you want to be notified of. Otherwise it’s nothing more than a nice feature to have in theory, but for practical use it’s more of a hassle than it’s worth when you’re facing wasting an hour+ just deleting unnesecary spam emails.

I have the same issue running TrueCommand 3.0.1 in docker and getting multiple sessions warnings that keep increasing as long as I have the app open. I have tested with Chrome and Edge, and it looks like the issue only happens when connecting from Chrome. With Edge, I do not get any multiple session or multiple session warning messages.