VGA to HDMI no display past POST (VGA text mode issue)

Hello everyone,


I have an ASRock C2750D4I with only VGA as display output. Although my motherboard has built-in IPMI, I’m trying to setup a PiKVM as a side project and to have a backup, should the built-in IPMI fail me (as it already has in the past). The PiKVM only has one HDMI input so I bought a VGA to HDMI adapter.


I get a signal when I’m in the BIOS or with a graphical OS (I booted a small Linux distro just to confirm that), but as soon as TrueNAS tries to boot, I’m left with no signal through the adapter, while the built-in IPMI still works.
I confirmed that the issue wasn’t the PiKVM by using an external monitor connected with a DVI<>HDMI cable to my adapter : the monitor showed the same behavior. I didn’t have a VGA monitor at hand to confirm that full analog signal works fine.

Solution (almost)

I still reached out to the PiKVM support team on Discord and, through my research and their help, we came to the conclusion that my motherboard is sending a “VGA text mode” signal that my adapter either doesn’t support or transforms to a resolution/refresh rate combo that PiKVM doesn’t support.
I invite you to read our exchanges in the PiKVM #support Discord channel if you want the full details, from 2024-06-01T22:39:00+0000 to 2024-06-02T13:02:00+0000 (sorry for the timestamps : I initially put links but, as an old user who just created his account on the migrated forums a new user, I’m not allowed to put more than two links in my post :upside_down_face: so I only kept the most important ones).

Thanks to this post, I managed to go one step further and receive signal from a little bit past TrueNAS’ boot menu (I guess from the moment the tunable gets loaded/applied), all the way to the login prompt. From there, I can use PiKVM fully. I just followed the instructions, the only difference being that I used hw.vga.textmode=0 instead of hw.vga.textmode=1, since I wanted to disable VGA text mode and not enable/force it.

Remaining problem

So that’s better, but I would like to be able to use my server with PiKVM under any circumstances. In short : I don’t want to be forced to use the build-in IPMI or an external VGA monitor to get to all settings and see all the information displayed, just because of this VGA text mode.
So the question is : is there any way to disable this mode altogether on my system at the BIOS/boot level ?

Things I’ve tried

  • I didn’t find anything in the BIOS.
  • I’m not very familiar with GRUB but, from what I found, TrueNAS might be using it and there might be some setting that I can change there, like the kern.vty one mentioned many times like here. I tried to change this without success. But again, not being familiar with GRUB, I might have missed something when trying to follow the instructions.
  • I ordered another adapter that is recommended by PiKVM in their documentation for their DIY version but I haven’t received it yet, and I can’t help to think that trying to make VGA text mode work is not the right way : I think that we should be able to disable such features somehow, so that everything would work no matter what adapter is used.


Motherboard : ASRock C2750D4I (BIOS up-to-date)
OS : TrueNAS Core 13.0-U6.1

Any help will be greatly appreciated :blush:

Please do not hesitate to ask for additional information

Thanks in advance


1 Like

Hello everyone,

I have some news regarding my issue and I thought I would keep you posted if it can help people in the future.

Like I said in my post here and on the PiKVM Discord support channel today, I ordered another adapter for less than 1€ with shipping (at the time I placed my order) on AliExpress that is recommended by PiKVM in their documentation, in order to try another hardware solution, should I not manage to find a software solution.
I received it today and it turns out to work just fine on a monitor I found, in all scenarios, where the other, more expensive adapter (~17€) didn’t.
I still have to wait for my replacement PiKVM to arrive in order to fully confirm that the new adapter works for my needs (my goal is to not use a monitor at all), but I’m pretty confident that it will.

So I will abandon the software solution, keep the new adapter, return the other one, and close this topic.

Thanks to everyone that took the time to read my post, even if nobody could help in the end.


1 Like