VNC for VMs not working / Error occurs during connection

I am facing an issue where I am unable to connect to the VNC server using the webview or an external VNC client like krdc.

The vast majority of reports regarding this issue are from around 2022 and I was unable to find anything that might be the solution.

I would greatly appreciate any pointers towards a solution and can provide more info if necessary. Thanks in advance

Look up the VNC port in the UI and use that instead of 5900.

Thank you for the response!

I already set the VNC’s port to 5900 and even when correcting it after having opened it in webview (the second digit from left ticks down by 1) it gives the same error.

I also tried creating an entirely fresh VM to no avail.

Which VM OS are you trying to install?

I had an Ubuntu 22.04.4 LTS VM before the error occurred, on which the VNC is now broken, I created a NixOS by cloning this VM and modifying the installed OS (had an SSH connection), VNC is also broken.

I tried creating a Debian 12 VM from scratch, but unable to do the setup process, as the VNC would not connect

Another option is to upgrade to Scale. You’ll need to use a spice client, but it will most likely work.

Are you using current stable CORE or CORE 13.3 Beta?

VNC is broken in BETA but there’s a workaround in the 13.3 BETA1 thread.

In current stable, you should still be able to install Deb 12 using a net install iso. VM’s with a graphical interface are not usable due to a mouse control problem which is fixed in CORE 13.3.

I am currently on 13.0, but not sure if I am confident in using 13.3 Beta considering stuff breaks already in stable. I have no off site backups (cold backup), which is stupid and I need to fix that, everything is for a home server for personal use, so a bit of stupidity is allowed.

Terminal is fine for me, but VNC isn’t even working for that, so i’ll probably be going the unattended install route with a preset allowed public key.

But it is kind of worrisome to see (important?) stuff being broken on stable for over a year…

I’ve considered upgrading to scale as I am much more comfortable on Linux, but that’s an endeavour and a half it feels like, so I need to find time to do it

I cannot reproduce not being able to connect. The observed bugs with VNC are all of different kinds. Please show your VM’s VNC device settings. Connecting with a 3rd party client is supposed to work perfectly well even in CORE.

I looked at the VNC device config again and saw that the address was set to I ignored it when I first looked at it, as it worked when i first created the VM before the VNC feature broke for me.

I then tried setting it to, the address on the local network and it worked! (

I was accessing my Truenas through a domain name, maybe that’s why was not working