Weird issue with DLNA PIM and Truenas

I have setup a gre tunnel over ipsec to connect two router:

Code: Select all

MINIDLNA server <---> Router1 <---> (Gre Tunnel Over Ipsec) <--->  Router2 ( <---> DLNA client           

I have then setup PIM-SM to forward multicast traffic from a testing MINIDLNA server and I managed to have the traffic successifully forwarded from R1 subnet to R2 subnet.

But as soon i tried to multicast the traffic of the real MINIDLNA server (a container in host mode installed on Truenas / Kubernetes) I quickly realized the traffic was not being forwarded.

I really don’t understand the problem, that seems related to the way truenas / kubernetes handle multicast traffic.

Everything works in R1 subnet
In R2 subnet clients can see only the test DLNASERVER not inside a container of truenas.

The MINIDLNA server inside truenas kubernetes can be accessed only from R1 clients.

I tried to inspect the traffic with wireshark… but i don’t really understand what is wrong.

Is there soemeone with previous experience with truenas / kubernetes / pim / multicast routing that can help me ?