Wow.... Dragonfish is taking me to new places

You can access them with Linux or FreeBSD, SCALE or Core. Doesn’t matter. It’s a ZFS filesystem at the end of the day.

Just navigate to the path:

The jail will not be “running”. However, its root fileystem structure[1] is accessible, no different than a mounted path of any dataset you create in TrueNAS.

  1. The jail’s “root filesystem” begins after the [...]/root/ in the host’s path. Therefor, while “inside a jail”, when you see /etc/wireguard/ from within the jail’s perspective, it’s actually /mnt/<poolname>/iocage/jails/<jailname>/root/etc/wireguard/ from the host’s perspective. ↩︎


That’s the thing, I tried that, the directory is there, but the files are missing. I wonder if I am lacking permissions to see them?

1 Like

Were the configs saved directly inside a jail’s filesystem? Or were they accessed via a mountpoint?

1 Like

AFAIK, they were directly inside the file system. The files inside the /root subfolder are there as expected (.ssh directory, all the PUB, etc. files for the passwordless logins, etc).

But the /config folder (which is where the _ecc SSL data and scripts to actually transfer the files were stored) is empty.

the /opt folder still has some older routerOS specific files in it, but not the more recent stuff.

So it seems like I have the permissions (checked with ls -al) but the files inside /config appear gone.

That suggests to me that you had its contents mounted from an external source. You can probably find out from where by looking at /mnt/<poolname>/iocage/jails/<jailname>/config.json.


Here is what I got inside that json file…

    "boot": 1,
    "cloned_release": "13.1-RELEASE",
    "defaultrouter": "",
    "host_hostname": "letsencrypt",
    "host_hostuuid": "letsencrypt",
    "interfaces": "vnet0:bridge0",
    "ip4_addr": "vnet0|",
    "jail_zfs_dataset": "iocage/jails/letsencrypt/data",
    "last_started": "2024-05-17 08:36:28",
    "release": "13.1-RELEASE-p7",
    "vnet": 1,
    "vnet0_mac": "XXX"

But there is no iocage/jails/letsencrypt/data directory…

Another one bites the dust. :dizzy_face:

@Constantin check this file:


@dan the “config.json” is what one configures in the GUI when creating/editing the jail’s options. The mountpoints are not included in here.

1 Like

The contents of fstab are as follows:

/mnt/pool/apps/letsencrypt/config /mnt/pool/iocage/jails/letsencrypt/root/config    nullfs  rw      0       0
/mnt/pool/apps/letsencrypt/hpilo  /mnt/pool/iocage/jails/letsencrypt/root/hpilo     nullfs  rw      0       0
/mnt/pool/apps/letsencrypt/truenas        /mnt/pool/iocage/jails/letsencrypt/root/truenas   nullfs  rw      0       0```


There it is. :point_up:

1 Like


I don’t consider this a permanent change - yet. For example, I have not made the pool ZFS feature flag / etc. upgrades, as the SCALE UI continues to remind me of.

For now, I am primarily interested in getting a big remote replication done. Only SCALE allows that thanks to its ability to resume large snapshot transfers if they get interrupted. CORE has to restart the transfer from scratch every time and given how reliable Comcast is, that means my remote replication task would likely never complete.

Overall, I don’t miss AFP even if I wonder a bit why it would have been that hard to include the code since iXsystems has done so much to maintain it. Similarly, I find some of the UI choices somewhat baffling but these kinds of choices are to be expected when folk are given free reign to reimagine the UI in the form they consider best. Ever try Designsofts Eagle PCB drawing program? :grin:

So my next task is to build a jail and try to rebuild the SSL certificate pull & transfer system that @dan allowed me to start using. (THANK YOU, @Dan!!!)

1 Like

I think you just gave me flashbacks. Eye bleach, stat!

1 Like

I still have a few systems that need it for Time Machine.

They’re currently backing up to an old AirPort Time Capsule thing (but it’s creaking).

I’m considering using a Core VM to serve that need

I am in the process of decommissioning those systems but the removal of afp (via scale) occurred first.

1 Like

I may still have a few in case you need one. They make great SMB1 file servers and they are usually very reliable. Airpost base stations never did break performance standards, just like my upgraded 5G ipods with 700+GB of flash on them… but at least the Airport base station extreme featured a USB2 connection, not USB1 like the 5G iPod!

1 Like

The UI of that program can only be described as… particular… or… an acquired taste. But as free / low cost editors went it was the best game in town at least until Designsoft was acquired by Autodesk and they started down the extortion path. I’m so glad I still have my old binaries to run.

Sadly, I have to do it on one of my older Intel Macs since that version of Eagle is 32 bit and hence I have to run it in a Mojave Parallels VM.

…and until KiCAD was released. Free software, no limited, and a much better UI.

1 Like

KiCad was around by the time I was using Eagle. But it was rough around the edges and didn’t have extensive parts libraries available for download like Eagle did. I also got into making libraries for the Teensy community and my own projects. If I didn’t have all that experience / baggage with Eagle, I’d likely transition to KiCAD.

I remember the Teensy[1]. It was key to this project of mine (for which I used Eagle for the PCB layout):

KiCad seems pretty good these days, and has a pretty extensive parts library, though still probably not as large as Eagle’s. But it worked for this:

and this:

  1. Yes, I know they’re still around, but I haven’t used one for some time ↩︎

1 Like

I came along later, developed libraries for the 3 series, components, even the underlying bootloader chips and MCUs, as I rolled a few boards of my own. The Teensy is an awesome MCU platform and the Arduino community owes so much to Paul Stoffregen for dragging Arduino into the 32-bit era.

What I found particularly hilarious was the awful Due that they had to release in response to the 32-bit Teensy 3 series, resulting in a MCU where over 1/3 of the pins were unreachable and many of the MCU core capabilities therefore could not be accessed. Eventually they got it right but the Arduino project is as good as indicator as any why competition is good. They had gotten fat, dumb, and complacent.