13.3 BETA.1 Call for Testing

Just a quick update on 13.3-BETA.1 testing. It’s been out a couple days now and we’re eager to see more community folks give it a whirl and report any issues. We’re keeping an eye on the numbers and as of right now the overall count of testers is low. Compared to Dragonfish, we are seeing less than <4% of the testers over the same period.

That said, we are asking for an assist from any of our community CORE users. We’ll keep an eye on it over the next few weeks. If we don’t see enough testing systems right away we may push back the RC1 timetable to give a bit more time to shake out any lingering issues. We’d like the eventual launch of the .0 to be of the highest quality possible, and the more testing we have will help us all towards that goal.



Getting feedback is critical to delivering quality. Since 13.0-U6.1 is the most popular version ever, we will be reluctant to release without a large number of testers. We will delay RC.1 and RELEASE to get that testing and quality assurance.

If you do test 13.3 BETA, please either report bugs or respond here with your experiences. If the experience is positive, that will encourage more users to test and accelerate the process.

Perhaps I am missing something? The 13.3 RC candidate is not showing up in my menu options.

Sorry, typing on my phone.

Go to the documentation and search for updating, then look under “manual updates”.

1 Like

Thank you, John. I appreciate the pointer.

I wonder why all the SCALE RC / BETA / release versions show up though and not the CORE BETA. That’s kind of inconsistent.

It’s also odd that TN CORE is not labeled as such in the menu…

@Kris and @Captain_Morgan, I suggest you add a link to the manual update file in this call for beta testers. The more barriers you put up to BETA testers, the fewer will help out.


I’m running the beta on a production system (small production) but no VMs, only jails. They seem to work still.

1 Like

Downloading now … I’ll give it a whirl (pretty slow download though :grimacing:)



Mine failed it’s first task - replicating from 13.3 to a 13.0u61 system. I am not going to risk updating multiple systems. I’m out.
Screenshot 2024-05-15 at 23.07.39

The 13.3 beta1 manual update file is here.

Update to beta went without a hitch … both Plex and UniFi 8 Controller jails are still working just fine

Looks like the system “shell” is missing from the GUI?


I rolled back my two production systems because of the replication bug. (NAS-128866)

If you publish a second beta or help me to apply the fix manually, I would upgrade again. Replication must work, sorry.


The ticket is not public. :slightly_frowning_face:

It’s solved and the fix committed. I (and everybody else depending on replication) just need some instructions to patch my NAS manually so I can continue to run and test the BETA.

I’ll possibly just dig in the commit later today and try to apply the changes - with vi(1) if necessary. :slight_smile:

@kris I also deleted the debug files from the issue in JIRA - so I guess it could be made public again.


Shell isn’t missing - it was removed since the consensus was that iXSystems shouldn’t ship something that buggy and iXSystems also doesn’t have the resources to fix it.

Replication still works for me…

The bug seems to only show itself when using SSH+NETCAT transport. Switching to SSH only fixes my replication tasks, too.


Thanks. It’s public again.

Thank for trying one system… finding bugs in BETA versions is precisely the goal. In this case, replication on netcat to older versions.

As a general rule, we’re not recommending production systems on BETA. Spin up a VM, use some spare hardware or try it on a non-critical system. Diversity is useful at this stage.

If you do find a bug, try the Nightly version after it is fixed.

1 Like

Updated 2 systems (old AMD & newer i3) to beta yesterday (very simple - just smb guest access). Reporting was broken on i3 but gui offered “fix” which worked. Not replicable. Still miss loss of the shell within the gui. Otherwise, no issues identified.

Well, I have nothing but production here… but I thought I’d take it for a whirl anyway.

Any idea why like 8 versions / flavors of SCALE release candidates (including betas) are available per the update menu but not the Core BETA?

Core BETA should be on the update train list, we confirmed that yesterday anyway :slight_smile: