Actual installs on uGreen hardware - observations, experiences & tips

OK - I have a DXP2800 (2-bay 3.5 + 2 M2 slots RAM upgraded to 16GB, N100) and I’m doing due diligence prior to putting TrueNAS Scale on it. I looked at the existing threads and they’re mainly on discussing the upcoming hardware but now that they have shipped, there’s a need for a thread of what people have actually done with the uGreen hardware and TrueNAS.

So, anyone running TrueNAS on uGreen hardware. Any issues in loading it? Any tips on doing it?

Thanks in advance

Yes. My XP6800 Pro has been SCALEd for 3 days by now.

  • Upgraded the RAM to 64 GB.
  • Made an image of the internal boot SSD using Clonezilla since there currently is no recover image available and installed SCALE.
  • Drives are a HDD mirror with 6 TB for data like Time Machine backups and documents plus a M2 SSD mirror with 1 TB for VMs, containers and the system dataset.

Overall performance is fine. The only thing that feels a little odd is the temperature reporting in the dashbord. Sometimes when there’s a load peak you see something around 70 to 80 degrees Celsius one or two cores. But in the next moment all cores are back to their normal 40 degrees.

And the LEDs don’t work.

1 Like

Just installed SCALE on my 6800, though I just removed the factory boot SSD and replaced it with another one. I’m running badblocks on a few drives in there to get an idea of how well it cools them. As you note, the LEDs don’t work; I’d like them to, but it isn’t a big deal (and I knew about that beforehand).

Edit: Drive cooling doesn’t seem great. After a few hours of badblocks, drive temps are 47-48°C. That’s in a pretty warm room, though. I’ll check again after the door’s been open for a bit.

My HDDs report 40°C after a while of normal operation.

That’s not so much more compared to the previous Microserver G8 in which HDDs reported 35°C in the same room. The room is in the basement of my house and has a temperature of 20°C all year round.

I tried OmniOS/napp-it and CORE 13.3-BETA2, both of which worked just fine on the 6800, but both needed a separate NIC (I put in a spare Chelsio T420 I had). But as it’s looking like I’m going to be spending several months away from home, it’s back to SCALE and I’ve ordered a set of drives for it; this is going to be my NAS away from home. Just need to decide which m.2 socket I’m going to use for the Apps SSD.

The 4-bay Plus model, and the 6- and 8-bay models, have the OS on a m.2 SSD. That’s easy enough to replace to install TrueNAS (or any other OS) on. But the 2-bay and non-Plus 4-bay models use eMMC for boot, so you’d instead need to use one of the other m.2 slots for your boot device.

Otherwise, Ctrl-F12 on boot to get into the BIOS, disable the watchdog, set boot device appropriately, and Robert’s your father’s brother.

1 Like

For the LEDs, this looks relevant:

There’s an issue on that repo that describes installing this in SCALE, but there seem to be a few bugs there. I’m able to install the scripts and kernel module, but the drive LEDs just stay on solid.

But one interesting piece of information is that they aren’t just white LEDs; they’re RGB, so they can be set to any color you like. So they could, e.g., turn red on a drive failure.

1 Like

I am able to get close enough to 10 Gbit/sec out of the onboard NIC on the 6800:

root@nas[~]# iperf3 -c
Connecting to host, port 5201
[  5] local port 50594 connected to port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  1.10 GBytes  9.43 Gbits/sec    0   1.73 MBytes
[  5]   1.00-2.00   sec  1.09 GBytes  9.41 Gbits/sec    0   1.83 MBytes
[  5]   2.00-3.00   sec   884 MBytes  7.41 Gbits/sec  314   1.74 MBytes
[  5]   3.00-4.00   sec  1.10 GBytes  9.42 Gbits/sec    0   1.74 MBytes
[  5]   4.00-5.00   sec  1.09 GBytes  9.41 Gbits/sec    0   2.01 MBytes
[  5]   5.00-6.00   sec  1.10 GBytes  9.42 Gbits/sec    0   2.01 MBytes
[  5]   6.00-7.00   sec  1.09 GBytes  9.41 Gbits/sec    0   2.01 MBytes
[  5]   7.00-8.00   sec  1.10 GBytes  9.42 Gbits/sec    0   2.11 MBytes
[  5]   8.00-9.00   sec   914 MBytes  7.66 Gbits/sec    8   1.39 MBytes
[  5]   9.00-10.00  sec  1.06 GBytes  9.11 Gbits/sec  170   1.36 MBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  10.5 GBytes  9.01 Gbits/sec  492             sender
[  5]   0.00-10.00  sec  10.5 GBytes  9.01 Gbits/sec                  receiver

iperf Done.

Edit: For this test, my Ugreen NAS was connected to a Ruckus ICX6610-48P switch via a RJ45-SFP+ adapter. The other end of the connection was my main SCALE box, connected to the same switch using both ports of a Chelsio T420 NIC in a LAGG interface. Both of those connections are fiber with optics on each end.


This is expected, mostly.

The dxp 6800 has two performance cores which ramp up to turbo speed for ~50 seconds, then settle back down to their normal power profile.

With the suboptimal cpu heatsink ugreen installed, you get temperatures approaching 100C for that short duration.

What? You just need to generate a Backup TrueNAS Configuration File, very simple and small. When you need to rebuild the boot drive, Reinstall SCALE from the ISO Image, once bootstrapped you can upload your TrueNAS configuration file and BAM! you are rebooting and bringing your system back to life.

EDIT: I mis-read the part about backing up the OS that comes with the system. Thanks @dan for pointing that out. Then I personally use a backup program (Acronis True Image) to backup the boot drive, I do this with each new laptop we buy and I save that image just in case something goes wrong. Of course it is likely more fool-proof doing what @dan did which was just replace the boot drive and then store the original somewhere safe. Label it so you know what it is 2 years down the road.

1 Like

There’s no way to generate a “backup TrueNAS configuration file” from the Ugreen OS that’s preinstalled on these systems, nor is there a download available of that OS. You need to either make an image backup of that SSD or (as I did) just remove the SSD and replace it with a different one. Edit: or leave it in place and ignore it in the BIOS boot order.

This only matters if you want to preserve the original OS. And while I don’t see me using it, it seems a good idea to keep it just in case.

1 Like

This still seems to be the case. I’ve moved it to a climate-controlled room, installed new drives (yes, they are 7200 RPM; doesn’t seem like I can find any large drives that aren’t), and they’re 48-51°C running a long SMART self-test. I expect they’ll cool a bit when they aren’t doing that, but still warmer than I’d like.

I do think I’ll remove the magnetic screen from the back, though–it’s nowhere near fine enough to be a useful filter, but it’s going to block a fair bit of airflow. Maybe that will help a bit.

A new one was $18. Not a hard decision for me. But labeling it is definitely a good idea.

Another interesting finding is that the whole apps structure is much more responsive on my 6800 than on my main NAS–the one with 2x Xeon Gold CPUs and 128 GB of RAM. Adding the TrueCharts app catalog took a while (pegging the CPU for several minutes), but loading the pages, and installing and editing apps, are much more responsive. I doubt it’s the UGREEN device itself that’s making this change, but it’s interesting nonetheless.

1 Like

Actually Ugreen promised a real recovery image for later.

1 Like

I’ve got a 6800 also and I’m just beginning the configuration and testing phase. I’m installing TrueNAS on top of ProxMox. So far just a small hiccup after the initial install of TrueNAS SCALE where the VM didn’t want to reboot. Rebooted the ProxMox base and everything of importance is working now. DHCP gave TrueNAS the correct IP address but TrueNAS didn’t populate default router, DNS, and NTP; so I had to manually configure these.

It seems that the front panel LED’s are controlled by some sort of utility service that UGreen has developed and installed in their base OS. From what I understand, UGreen’s OS is based on Debian, so it should probably work with SCALE if somebody can locate it.

To make things a little simpler, I went ahead and replaced the boot NVME with a new 1 TB stick. That way I can just drop UGreen’s back in if anything comes up.

Also have a 6800 Pro running TrueNAS for a week or so now.

Completely disabled the UGOS drive through the boot menu (just to prevent myself from accidentally overwriting it or something silly :slight_smile:) and connected an NVME drive in an external enclosure through one of the USB slots on which TrueNAS has been installed.

It’s all been working pretty well, even the LEDs using the binary method described here, with a slight update to the example script to make it work with the 6800 Pro (which I shared in a comment on that gist).

The only real issue I encountered was the ZFS cache eventually completely filling up, causing the entire system to become unresponsive. It doesn’t seem to be specific to the UGreen devices, as I found an issue describing the issue here, including a work-around (echo n >/sys/kernel/mm/lru_gen/enabled which I’ve added as a POSTINIT script to TrueNAS, which seems to have resolved it).

1 Like