Apps are NOT seeing updates are available

Hi,

I have the latest TrueNas Scale Dragonfish instance (24.04.1.1) that i have been using and upgrading for the past couple of years, have been using Apps most of that time, I currently have 5 or 6 (mixture of Truenas and Trucharts). I recently realised none of the Apps had wanted to upgrade for quite some time. Finally got around to checking and i can see that newer versions are available in the catalogues but im not sure why they dont see updates are available.

For example
qBittorrent
Available in the TrueNAS Catalog - App Version: 4.6.5 & Chart Version: 1.2.12

Installed and working fine - TrueNAS Catalog - App Version: 4.5.2 & Chart Version: 1.0.11

The rest of the apps are Truecharts which i know aren’t supported but i believe the problem lies within my Truenas Scale setup.

I’ve tried refreshing the catalogues and while it shows me that they contain newer apps, none of my apps show as having updates available.

Any thoughts?

Edit - Just to clarify, All apps show as running, using RAM, have network traffic and are functioning just fine, they just show as up to date but they are not.

Have you tried to force refresh the apps Page with Shift+f5? The Apps GUI has a Coaching bug

Probably, but I don’t recall. Will give it a try and update.

Didn’t make difference, the page simply refreshed and showed nothing needs to be updated.

What about refreshing the apps catalog? Apps → Discover → Refresh Charts

No, doesn’t help. Actually thats something i often do anyway, to see if apps have been updated.

Thanks for suggestion though

Just one question: Is the DNS/gateway set up correctly in the “Network” tab?
Once it happened to me that for some reason the DNS and gateway settings has simply disappeared, and the same happened to me.

Didn’t the ones behind Truecharts stop updating their apps after the announcement from iX to change from Kubernetes to Docker?

Yes, i have appropiate IP’s for both

Yes–well, the SCALE versions of their apps, anyway. Looks like they’re moving along with their migration path, which will just run the apps as regular helm charts, and I understand they’re keeping those up to date. See:
https://truecharts.org/news/clustertool-update
and
https://truecharts.org/clustertool/

I also have this problem. None of my installed apps for Truenas or Truecharts are updating.

I have confirmed this with the installed versions and their online versions. I am a couple of versions behind.

None of my apps is showing as requiring any updates, but if I connect with the apps like Plex, they are all stating that there are upgrades available?? Which I confirm with the online versions.

I can manually refresh the catalogues without a problem, and no changes have been made to my network or DNS settings.

I can pull and install new apps from any catalogue, but I am not getting any updates.

I am running:

Dragonfish-24.04.1.1

To further explain :slight_smile:

Here is the Catalogue version of my Plex App showing on my system.

Now showing the upgrade version that should be used.

Can anyone help, please?

thanks
Gary

You’re using the truecharts version, and since truecharts stopped support for truenas since the announcement of iX to remove kubernetes in the next big release in oktober, you won’t get any updates for truecharts apps anymore.

Really@!! Thanks @LarsR
I did not see that announcement.

I suspect a few people are going to get caught out by that then :smiley:

Ok, so its wait until October, or move to TrueNas I guess ?

Truecharts is working on a migration path for ppl who want to keep using their charts, but it involves a vm with talos linux. If you want to stick with truecharts you’d have to migrate to that vm, for the native apps system of scale there wont be any updates.
Or migrate your apps to truenas or custom apps, since iX said that those will migrate to the new docker and docker-compose sytem that will be in the next update.
Your choice.

Truecharts apps won’t be migrated to docker-compose automatically like official & community charts or custom installed apps.

If you want to keep using truecharts apps, you’re going to need to follow their documentation when they have their system ready to go. That will involve installing their supported linux distro in a VM.

In the meantime, I’d be checking for security issues with those truecharts apps. They are no longer getting security updates. Not really sure I’d stay with them, they’ve effectively taken their ball home and left users out to dry.

OK, I wasn’t aware of this, so I guess it explains why most of my apps don’t want to be updated. but even the TrueNas app (only qbittorrent for me) doesn’t ask to be updated and if I ask it to install a new instance it get a much newer version.

What’s available in the Truenas catalogue:

What’s installed and is apparently ‘up to date’

I’d say it’s more iX who have done that: “thousands of folks are using this? So what, throw it out.” So now TC needs to come up with a way for their users to move, taking development time that could have been spent on lots of things including keeping the charts up to date.

Opinions can vary, of course, but I consider this 120% iX’ fault.

1 Like

Thanks so much for the background information :slight_smile:

makes sense now why apps are not updating!

TC could have said they are going to support their apps until DragonFish goes end of life. But they decided to freeze their app updates to work on a new solution. Which is totally their right, but they are leaving their users in a lurch.

Hope there’s no security issues with any of their apps between now and Oct. Nobody will look good if that happens.

No doubt they could have–and taken resources away from their migration process, which they wouldn’t have needed (or, at least, needed so quickly) if iX weren’t making massive breaking changes to their software.

I agree it’d have been nice if they’d continued to keep their charts up-to-date at least until the release of EE–but under the circumstances I can’t blame them for not doing so.

But in the end, I guess both iX and TC get what they want. iX doesn’t have to deal with Kubernetes, which Kris says they never wanted to do in the first place[1]; and TC doesn’t have to deal with iX moving the goal posts on them.


  1. Removal of K3s based apps from TrueNAS - #66 by kris ↩︎