Cannot import Pool after exporting it. When trying -f I get I/O error. Paid help offered

Hi Team,

I relied a lot on the redundancy instead of snapshoting or hacing backups and ended up losing all my data on my “Main” pool.

2 days ago, I restarted my proxmox server that has many services on it, one of them Truenas latest and it shows that 2 of my disks had some minor errors, I thought of exporting.disconnecting the pool then reimporting it as if it was for a new Install, after that I was not able to import anymore.

I used zpool import -f and it showed a message that I have to destroy the pool as there is an I/O error.

Is this issue because some of the disks had some errors that now it shows I/O error?
How can I spot which ones? I tried Smartl -a /dev/sda then sdb, then sdc, sdd and all shows without errors.

I am ready to pay if anyone is willing to assist to get it up and running to back up my data, thanks!!!

Some screenshots:

You need to post your complete specs and how everything was set up

Hi @SmallBarky
I am using Proxmox and connecting the 4 TB drives to the motherboard Sata controllers.
Connected the disks via command line:
qm set 10x -satax /dev/disk/by-id/ata-xxxxxxxxxx

Ntothing fancy at all, it was working fine until somehow I decided to do this mistake of exporting it.


The only command that seems to do something is: zpool import -fFXn

Now it shows : pool.import_find, but stays at 0 %

I did that yesterday all day and nothing happened. How can I know if it is doing anything please?

If you directly add drives like that instead of passing through the whole controller you are liable to run into the issue where the Proxmox host itself imports your pools, causing all sorts of mayhem when TrueNAS then, at the same time, tries to import them:

I am not sure how to best try to recover from your situation or if it’s even possible without data loss.

1 Like

You can try to temporarly run Truenas from bare metal.

  • safe your config file
  • install Truenas fresh on a USB stick or add second boot device as mirror
  • boot from this USB
  • restore config if needed
  • try to import the pool again
  • pray proxmox did not corrupt the pool

This will at least tell you if its just proxmox messing with your pool.

As written above, you should absolutely not pass individual discs to truenas. You need to passthrough a entire controller. Sata or a HBA.

@Farout I tried in bare metal and the same, which means proxmox might not be the one that was messing up.
I also tried to interchange Sata cables between disks, tried to leave 2 disks at once and import and I always got that nasty IO error. When I use the zpool import without anything it shows my pool and it is not degraded or anything, which means my pool seems to be intact.
I have been having issues with truenas and it definitely not a reliable solution, as I noticed issues with kubernetes and disks showing degraded after a simple reboot and many other issues.

If someone is expert I’d pay for getting back my pool, then moving as far as I can away from Truenas and use Xpenology or simply get an official Synology hardware since Openmediavault is also not good for me. please DM if you feel capable to restoring my pool and I will pay what I can for that, thanks!

man i had such a hard time trying to find a way to export a pool but couldnt and would get a busy error or something like that…so the only solution i had was to just take my drive out, stick it in my other client pc and wipe it in diskpart in cmd shell lmao…sucks but that was particular to my situation where i didnt really need the data on it since i had a backup but i didnt want to cause it would take like 13hrs to copy over all my media lol!..but did it cause i didnt feel like frying my brain anymore and let the drive copy all night and most day…

…but im sure you can find a fix with someones/pro truenas mod dude here lol…good luck man, some of the bugs and error we face in our homelab journey is a real bitch

but you dont need to be paying people man, lol idk why these posts are becoming more popular…someone will help, or you have to really just keep searching if you need to restore your data…you can pay for their support i think…so theres that i think