Can't restore config in fresh install--Yikes!

As discussed elsewhere, I’m in the process of moving my SCALE install from Proxmox to bare metal. I backed up my configuration file (which, I note, is a .tar file, instead of the .db file in previous config backups; it’s about 800k), downloaded the installer, installed onto the system disk, and booted into the fresh install.

This worked; I got to the “console setup” menu, which told me what the new network details are, and I was able to log into the web UI using these details.

However, I am unable to restore my configuration. I go to the sidebar, select System Settings → General, then from the upper right dropdown go to Manage Configuration → Upload File, and choose the tarball, and then I get a modal saying “Uploading and Applying Config”, that hangs forever, or at least for over 20m on two separate occasions. I’ve rebooted the box more than once.

Other things seem not to work either; if I click on the Storage tab on the sidebar, it doesn’t show anything, I just get the white-band-sliding-right “thinking” display. (Update: after another attempt or three, it sometimes goes to a screen saying “No pools”, and gives me the option to configure a pool; if I select this, the Pool Creation Wizard shows the actual disks on the system and the pools they belong to, and “Import Pool” shows my two pools. However, this whole process is flaky, and “Disks” seems to spin forever.)

This is rather terrifying to me; I have backups of the data but I need the system itself to work. What are my next steps?

(The system is the “New system” of my sig: Intel i7-14700k CPU, ASRock Rack W680D4U-2L2T mobo, 64GB ECC RAM, etc.)

(I also just realized, when testing one final time before posting, that rebooting the system from the UI doesn’t work; it goes to the light blue “system is restarting” screen, but doesn’t actually restart.)

Try force refreshing the page, or dumping web cache.

I had tried to force-refresh the page, with no joy. In fact, I got regular “Connecting to TrueNAS…” messages from the UI throughout the process, and often had to refresh the page and repeat whatever action I was in the middle of.

Next-day update: I gave up trying to restore the configuration, and I simple rebuilt the most important parts by hand: The disks were all visible, so I re-imported the pools, which went perfectly; I recreated the NFS shares; I recreated the networks. I’d already moved my VMs to a new system, so there wasn’t anything running on TrueNAS. And…everything is fine. It’s been stable overnight, everything else on my network is happily accessing it, etc.

I’m too nervous to try to restore the config again, but I’ll probably save this config, for no obvious reason…

If that happened thats probably the reason config upload did not work. Maybe a network conflict?
Would be interesting to check browser console log under developer mode for error messages.

Based on this, I’m wondering if you didn’t simply lose UI connectivity because the uploaded config contained a different network setup from the one you were using to access the new install.

That is in fact what I was most worried about, and asked about in the linked post at the top of this thread. I don’t know if that’s the cause! I’d expect, though, that this would be a major source of concern at every restore-from-config, so I’m surprised it’s not more widely discussed.

Or maybe I was having a bad day for other reasons.

Looking at that thread now, I think @william’s last comment there covers what probably happened here. Your fresh install used DHCP, but the saved config has a static alias or some other incompatible network details. So you need to at least manually update the network to match. If you enter your correct network details from the console before accessing the UI and uploading the config, you shouldn’t experience any disruptions.

1 Like