Console width is cut off

the console window seems to be cut off. How do I get TrueNAS use the complete width

Best answer is to forget the “shell” button exists in the GUI, and just SSH into the server.


The bug has been known for years. Unfortunately, it seems that replacing the broken code of the web console by actual working code, such as that of the “Processes” tab, would require a major reengineering of the whole OS, threaten its stability, compromise storage security, and risk ultimately trigger a full blown nuclear war between major powers. Or something like that.


I posted notes on how I set up a simple programming jail for myself. My notes include how to set up SSH access.

Please see below if you want to enable ssh access.

…or you could just enable it at the OS level through the GUI.

I feel the same way.

EDIT: It’s not like they fixed the Shell in SCALE where they could use that co-, oh wait.

Hey, buddy.