Import/add previously used TrueNAS disk (zfs_member)

Today I recognized that one of my two pools has no disk assigned anymore. I updated TN Scale from to 23.10.2 this week, but I don’t know, if it’s related to this, as this pool is used as a share for proxmox (shared storage) and rarely used. Today was the first time since weeks (or maybe months) I needed this share in proxmox, so I found the issue.

I tried to load the previous configuration (before updating to 23.10.2) and even rolled back (boot environment) to now again Without success.

Here’s the current status:

This was originally a mirror pool with two 2 TB disks. One SSD died last year and I was running it with the left SSD (without any redundancy anymore, of course). As the data is not really critical, it was ok for me. (I wanted to replace these SSDs in the near future).

But now, TrueNAS messed something up with this pool. The SSD seems still ok (passed SMART test), but maybe it will go offline from time to time. (But I will replace it anyway after I have access to the data again and can make a backup.)
I can attach it to another Debian system (not TrueNAS), but can’t mount it, as it is a “zfs_member” format.

How can I import this disk back to my pool WITHOUT LOSING the data on this disk?

I tried to click on “Manage Devices” and then “Add VDEV”.

The missing disk will be recognized automatically, but I really don’t know, what the note does mean for me! Can I safely proceed or not?

The other option is adding the unassigned disk.

Even here the original pool seems to be recognized from the unassigned disk. But in this case, there’s no warning or note:

So, which one is the better or correct option to get the pool back, so I can then immediadely try to backup the files. (I guess, the disk space is only 25% used and as I mentioned before, the data is not critical. But I would prefer to not begin from scratch.)


You are right the options you have shown are not right. You do not want to add the disk to another pool.

Either via GUI or zpool import you may be able to import the pool. Not sure if it works without force since the pool is degraded.

If the import works you should be able to access your data. Then you can either replace the missing drive with a new one or save your data and start from scratch with another layout / pool.
If you plan on keeping the mirror I’d replace the missing disk.

AFAIK (and I do not claim to be an expert) you probably need to export the empty pool first before you can reimport it.

thanks chuck32 and Protopia

Yes, I guess I need to first export/disconnect this degraded pool. I can’t import any pool at the moment (the pool listbox is empty), because TN probably only sees one unassigned disk with a pool, which is already there.

So, this settings for exporting should be safe? And after this, the import pool command should recognize the single unassigned disk and creates a new pool with this disk again, right?

Do I need to re-create the currently 3 assoziated shares for this pool too or will this be done automatically? (If not, I will first document the share/permission settings :grinning:)

Now I’m slightly confused, if the pool is exported why does it seem to show up in GUI?

Maybe you just need to online the drive.

Please post the output of zpool status and zpool import.

ok, I tried it. :grimacing:

Export of degraded pool was successfully:

Then I could select the import pool command, as the unassigned disk/pool was automatically recognized (this was not possible before):

BUT…the importing process seems stuck. At least there’s no visual progress for the last 10 minutes. (I don’t know, how long this normally takes for a 2 TB SSD, which disk size is not fully used.) I will wait…

Should only take seconds but maybe it takes longer because it will be imported in a degraded state.

good question. I don’t know, but I guess, I had the same issue as described here:

I did zpool status in the shell (before exporting the pool of course) and the pool was not shown. Only in the GUI (same as in the linked discussion).

I waited for more than 30 minutes and nothing happened. TrueNAS logged me off automatically and after login the pool is still missing. Even the disk is not visible anymore (Storage Dashboard > Disks screens loads forever.)

I had to restart TrueNAS and now at least the unassigned disk is shown again.
Here’s the result of zpool import:

(The 2nd offline disk is probably the SSD which died last year.)

Can I import the pool from the shell too? Maybe I get more information when it stucks as the GUI option.

(Maybe the SSD is defect and power offs randomly, even the content is fine and S.M.A.R.T. does not detect any errors. I don’t know…)

zpool import ssd_raid1_2tb

1 Like

If it doesn’t work with the GUI, you probably need a reboot, then see what the status is - and if necessary export it again from the GUI and switch to trying to get it working from the command line - because from the CLI you have a lot more options to deal with recovery situations.

Assuming you can get it imported and functioning correctly from the CLI, you can then export it from the CLI and import it again through the GUI and you should be good to go.