VDEVS Not Assigned after hard shutdown


TrueNAS Linux Scale

After a hard shutdown this happened.

On the command line…

sda is my boot drive.

I can see disk hdb and hdc
I can see TrueNAS in /mnt (my pool name) in mirror mode

…but when I run…

zpool import -f -F -R /mnt TrueNAS

…it outputs…

Cannot import ‘TrueNAS’: No such pool available

This screenshot is what I’m seeing in the Web GUI.

I’m a TrueNAS newb, I’ve searched the internet and seen a few posts with the same problem, but the fixes don’t work. Anyone know how to fix this?


Can you post the output of zpool status?

Also please list your hardware.

zpool status

pool: boot-pool
state: ONLINE
scan: scrub repaired 0B 00:00:07 with 0 errors on Thu Apr 25 03:45:09 2024
            NAME           STATE          READ  WRITE  CKSUM
            boot-pool       ONLINE        0     0      0
               sda3         ONLINE        0     0      0

errors: No known data errors

2 x WD BLUE 2 TB HDD (only a few months old) (My TrueNAS pool that’s not working)

Running on an old Acer Aspire AX3470-EB20P

What does zpool import yield without any arguments?

We had a similar issue a few days ago, unfortunately OP didn’t report back if it worked. It’s weird that the pool is shown in the GUI.

Do you see the disks under Storage / Disks?

Edit: if the disks show up as members of an exported pool you should try exporting and importing the pool again.
Here’s the mentioned thread.

@Protopia suggested exporting the pool in the GUI and then try Importing it again in their last response. I feel this would be the next logical step.

LOL. Whilst I have a lot of background in Servers and massive storage systems (EMC), I do not consider myself to be either a ZFS or TrueNAS (or Linux) expert. So, whilst it is lovely to be referenced as if I am an expert, please get some corroborating advice first.

I was referencing this thread (should have linked it)

I think in this case exporting and importing it is worth a try, depending on whether the disks show that they belong to an exported pool.

Edit: edited my original answer.

admin@truenas[~]$ sudo zpool import
no pools available to import

During bootup there is a strange message about SATA ports. But it goes by to quickly…

failed to identify INIT_DEV_PARAMS on ATA3

If I install these drives on another trueNAS system will they be imported?

This computer is ancient, originally running WIndows 7.

I don’t know if its the computer or the drives.

TrueNAS isn’t even showing sdb

I’m new to TrueNAS, this is my first time using it.

I think you need to go into BIOS and check that the disks are recognised by the BIOS.

You may also want to check all the BIOS settings and ensure they are optimised for Linux and to enable EUFI if your BIOS supports it. Then (if you have no data on your system yet) reinstall and see if things are any better.

If it still doesn’t work, please post full details of your NAS hardware.

Good idea.

1 was viewable in the BIOS but listed as 0 GB
The other was not visible.

Plugged them into a different motherboard, same thing.

Only bought them a few months ago. WD Blue 2TB HDD.

Looks like the drives got roasted. The boot drive SSD was fine. Reinstalled TrueNAS and it wouldn’t detect the HDDs.

Thanks for the help everyone.