Jellyfin plugin inaccessible

About 4 months ago, I bought a cheap mini PC and a hard drive to use as a storage server. I already knew I wanted to put jellyfin on it so I used the plugins feature to create the jail and configure it automatically. This worked really well until I tried to update it via the same plugins page. I went from version ~10.8.1 to 10.9.2 again, by using the ‘update’ button on the plugins page.

This immediately caused my to loose access to the web interface via port 8096. Since I had not done any heavy config of jellyfin, I thought it wouldn’t be a bad idea if I just deleted the jail and reinstall jellyfin altogether.

This did not help and I have tried every solution I could think of.

I have verified that jellyfin IS running in the jail:

This is how I have configured the jail:

My HP mini-pc:

  • i5-6500T CPU
  • 16GB RAM
  • 1000baseT ethernet
  • 2X 512GB SSD
  • 1TB Samsung HDD

TrueNAS install:

  • TrueNAS core 13.0-U6.1

Help would be GREATLY appreciated.

Truenas core plugins are broken - it just easier if you manual install your app via jail/vm

1 Like

Create a jail, then from the main TrueNAS system run

iocage set allow_mlock=1 jailname

Then enter the jail and run

pkg install jellyfin
sysrc jellyfin_enable=yes
service jellyfin start

mlock was already enabled when I created the jail and the jellyfin service is already set to start on boot so I don’t think that is the issue. Also, installing jellyfin via pkg only allows me to download version 10.8.13, not the current 10.9.4 version.

I don’t really want to use a VM as it is quite resource intensive. I am also running into the same issues when trying in a standalone jail.

This is the only version I can download.

What I meant was delete the plug-in and install it in a manual jail.

I have tried that but again, I only have the option to install version 10.8.13. Am I using the wrong version of jail?

Does that version work?

Mine returns the same version. I wonder if the plug-in installs it from source?

Nevertheless, plug-ins are dead. That looks like the latest version according to freshports.

Not really, the client version requires server version 10.9.4

The plugins is just pulling the artifact from Releases · Thefrank/jellyfin-server-freebsd · GitHub which has the version 10.9.4

Ok, I see the pkg has been updated on freshports. You will want to switch the repo to latest instead of quarterly to use it. To do this, run these commands inside the jellyfin jail.

mkdir -p /usr/local/etc/pkg/repos
echo "FreeBSD: { url: \"pkg+\${ABI}/latest\" }" > /usr/local/etc/pkg/repos/FreeBSD.conf
pkg upgrade -f

After this you should be able to get version 10.9.4

1 Like

I get:

What does ABI do? Does it need to be a variable?

Try to

pkg update && pkg upgrade

before running the commands.

Same error unfortunately

@pmh might have to jump in here. I’ve never seen that issue and google doesn’t seem to bring up any immediate relevant results.

What’s your jail version BTW?
And your TrueNAS version?

Jail version: 13.3-RELEASE
TrueNAS version: 13.0-U6.1

Try a 13.2 jail.

Things were added in 13.3 that require the TrueNAS host to also be on 13.3 when using 13.3 jails.