Monitoring ISP Bandwidth

Hi all,

In the recent light of a ‘new’ ISP investigation here in Belgium where it’s very obvious that ISP’s are ‘scamming’ us. Overpriced, low quality hardware, much lower speeds than advertized, …

Personally i’ve been experiencing problems since 2015-16, many ISP technicians came onsite to change the couplings etc of the entire COAX chain.

So from the TAP (Telenet Acces Point - street side), my internal COAX hub, new COAX cable straight to the modem (a thick expensive one…).

The ISP’s modem (mandatory - till november 2024, then we are allowed to use our own…) is brand new, DOCSIS 3.2.

The modem itself is connected to an ASUS RT-AX92U (Gbit) with a 1m CAT7 cable, so that should be ample to get 1000Mbit down.

So from the hardware side, everything has been double checked, replaced, upgraded, … (which the Telenet technician confirmed)

Now, fastforward 2024, i just don’t achieve 1000Mbit speeds.

The funny thing is, they advertise ‘speedboost’ for an extra 15€/m. Of course, when applied for a month trial, i hit 1Gbe without any issues.

Now we all know that ISP’s, everywhere on this planet, are scoundrels to say the least…

After watching the docu on TV, exposing those bad results, the makers of the programme listed some tips.

One of these is testing the speed over different periods of time, this will assist your casefile. (if you plan on complaining :wink: )

So basically i’d like to set up a testing routine on my server.
I’ve stumbled upon Netdata + speedtest-cli integration which is exactly what i want. (i think, just test ISP speed side, every day/week/…, and log those values)

Netdata is available in the apps, it runs perfectly.

The integration with speedtest-cli is where i’m running with my head against the wall.

I’ve been trying to install this through the info mentioned, but the shell wont accept those commands. (tried both in the container shell, as well as the Truenas Shell, as i was not sure exactly where to enter these)

Has anyone got this working, or maybe has an alternative that works out of the box?

Thank you!

Enjoy the rest of your sunday :wink:

As a different path, consider running GitHub - alexjustesen/speedtest-tracker: Speedtest Tracker is a self-hosted internet performance tracking application that runs speedtest checks against Ookla's Speedtest service. as a custom app. It’s distributed as a Docker container, and you can set it to run tests on whatever schedule you like. I just set it up the other day, though not on my NAS, and it seems to do the job pretty nicely.

1 Like

Thank you Dan, this seems to be exactly what i need.

Now on to get started with docker… :cry: (total noob)

Is this still relevant?
Docker on Truenas Scale

Currently running Bluefin. (need to migrate Rsync modules tos SSH still…)

That’s likely to be a problem. Under Cobia or Dragonfish, the easiest way to get this running would be to install the app that Truecharts provides, all point-and-click (I hadn’t realized it was available there when I posted earlier). If you don’t want to use Truecharts, Apps → Discover → Custom App, and you can probably figure out what parts of the docker run command on the Github repo I linked to would go where.

But I’m not sure either of those would be viable under Bluefin. If you aren’t able to upgrade to at least Cobia, you might be better off setting up a VM with Debian or Ubuntu, installing something like Dockge or Portainer in it, and using that to manage your Docker stuff, might be the better way to go.

1 Like

Useful because some unscrupulous ISPs may choose to prioritize ookla Speedtest traffic

1 Like

Not sure if it works on Bluefin (I think it does), but certainly does on Cobia and Dragonfish.

IMO, Sandboxes with Jailmaker is the best way to run Docker on Scale


Interestingly, I get considerably lower bandwidth (by 20% or more) on the speed test than I do via NNTP.

How remote is the news server?

I don’t honestly know how remote it is, physically or in terms of the network, but 12 hops via traceroute FWIW. But I can get the gigabit speeds Comcast promises me–or at least very close–that way, but speedtest-tracker is showing in the high 700s. Better than the speed test on my OPNsense router, though; that was showing in the high 300s.

1 Like

Thank you Dan!

I’ll get onto migrating to the latest stable build.
It’s just the Rsync thing.

Truecharts is already set up, so i will give it a try ;).

Thank you!

I’ll check that one out too!

So, i filed a complaint last friday (speeds 5-600Mbit/s).

Devoted saturday with testing, checking the wires, reboot everything, … the speeds remained the same. (5-600Mbit/s)

But in the evening i spotted something funny, all of a sudden i ‘felt’ faster.
Ran some tests again, en got +950Mbit/s. Which is exactly what i’m paying for!

The thing is, i was transfering bulk data through a VPN (NordVPN). (+950Mbit/s)

So i did Ookla’s speedtest then i disconnected from that VPN, and got 750-800Mbit/s.

So i went testing with/without VPN, and came to the conclusion that WITH VPN it’s faster.

Now, i’m not a network engineer, but i imagine that connecting through a VPN service ‘should’ be slower? As you add another service/connection point to the chain?

Also, the sudden bump in speeds seems somewhat shady…
It feels like my ISP is saying “we’ll give them wat they pay for, after they start complaining”.

That is also what i experience with my Asus router:

Notice how the speed is very irregular and the 916.55Mbit/s is just after a reboot.

When i ran a speedtest through the router (Asus uses Ookla too), i compared it against a browser test (Ookla), the browser was stating 900-1000Mbit/s regularly.

So that’s exactly why i want to monitor through my server as well, through an independant platform that’s capable of it.
The Asus modem is probably running hot while running that speedtest (it is…) and is keeping things in balance. (also an AP)

(all testing is done wired)

Help, what am i doing wrong?

I’m really trying to get this running but i cannot succeed in getting SSH + key’s working (Rsync).

Also posted a question but no one seems to answer or give the slightest direction… :expressionless:

Is Rsync correct for me?

Backup Advice

Very frustrating to not know where to start or figuring out things…