Mouse not working on TrueNAS CORE 13.0 VMs



I’m trying to install Ubuntu on a VM but the problem is that I’m doing it during the slow hours on my night shift. As a result I only have my iPad with me.

I quickly run into a problem though; when I use the built in VNC to install Ubuntu I can’t control the mouse cursor.

I can see the black normal looking cursor in the corner but when I use my finger or Apple Pencil it moves a tiny black cross on the screen instead of the cursor. And the small cross can’t do anything so I’m not sure what the point of it is. Using the touch screen keyboard works fine.

A quick search says that novnc should support touch screens.

Does anyone know what could be the problem?

Truenas core 13.0 U3.1
Edit: I have now updated to U6.1 but the problem persists.

Thanks :slight_smile:

@pmh any ideas?

So, I’m now laying in bed with my laptop and I tried it again to see if it was just a problem with my ipad but it wasn’t. The same problem exists on my macbook pro. The problem is not exclusive to touch screens in other words.

On both my ipad and my mbp I’ve tried it with safari, firefox and chrome.

I’m really tired at the moment and I must go to sleep, tomorrow after work I’ll try it on my windows machine.

Mouse doesn’t work. Known bug, will be fixed in TN CORE 13.3.

Why do you need a graphical UI on a VM on TrueNAS?

1 Like

Well, that explains it. Thanks!

I wanted a gui just to play around with when I’m bored at work. I’ve never used linux desktop version so I guessed it was time to play around with it.

I’ve also been thinking about the idea of learning C++ during the slow hours at work but I don’t want to lug around my ancient and big mbp to work. So I figured that while I’m in the early stages of printing “Hello world” I could use a vm on truenas. I’m assuming it’s far from ideal but I figured it would work well enough for an absolute beginner until I either get bored or decides to buy a more suitable device for it.

Using a suitable hypervisor right on your desktop machine would probably be the better choice. Even with a working mouse VNC is not fun to use at all.

Unfortunately it looks like 13.3 doesn’t fix this issue, and adds a new issue. I am using GhostBSD and the mouse is still not working even after an update to the nighly version of 04/20

The new issue is now the display is not updating at all on any of my VMs including those that worked fine before. (Including my Linux arms, Debian based)

Has anyone tested with 13.3 and Ubuntu?

I did run an Ubuntu VM with the first releases of 13. Had a few issues with VNC but beyond that it ran fine.

The current realease of U6.1 has the bug of mouse not working. But it needs to be tested on the 13.3 nightlies. I found that on the 13.3 nightlies everything freezes and the VNC display does not update at all, let alone move the mouse.

I meant, just run a jail without the GUI. It’s all freebsd.

Trust me, I would, but I have 2 limitations

  1. I need sound (TrueNAS is build without sound stuff) see Sound Cards on TrueNAS CORE
  2. I need a sip app

If I could somehow have a virtual sound device inside a jail, and pipe the sound to ffmpeg/icecast then that would take care of 1, but for 2, I’m using Linphone currently which has a GUI to make calls.

Use an ubuntu server VM then.

And you need to make calls from a NAS? :thinking:

Anyway, I had no issues with the mouse with my Ubuntu VM.

This was on 13.3 right?

It’s complicated, but I’m streaming a conference call via icecast.

Linux over FreeBSD? C’mon…

Nope, 13.0

@kris In the current 04/23 CORE nightly, the mouse does seem to work, but the display is not updating at all. I have to refresh the page to get the updated display. Would this be an issue with the nightly or maybe my system?

This would be the Ubuntu mouse. The GhostBSD mouse still doesn’t work…

Nightly image is still pretty unstable, but we also don’t officially support the VM functionality with bhyve on CORE. Unclear if that will be addressed for 13.3-RELEASE until we know if its something we broke as part of the update, or a new regression from upstream 13.3 FreeBSD updates.

1 Like

Thanks. Will wait for the stable release then.

What? This is new to me.