No bootable device after TrueNAS fresh installation

Hi everybody,

I recently got upset about qnap QTS (I have a qnap ts-453D) for being pretty closed, and not letting me do what i want, so i tried installing TrueNAS Core.

The installation was good until i rebooted, after removing the usb stick and starting the nas again, no boot option was available except the default qnap OS and the built-in UEFI shell.

btw I tried installing in UEFI and in BIOS but I get the same results.

Try to wipe the boot-drive before doing the installation.

I don’t know the specifics of your qnap device or if it allows for installation of other OS. Can you select the boot medium in BIOS (if you can access it) / on which drive did you install truenas?

I think you have to remove the build in sata dom where QOS is installed on. Otherwise the qnap will always try to boot from sata dom. If you have access to the bios you can try to changeg the boot order from satadom to ssd/whatever you intsalled truenas to.

1 Like

already did it with windows diskpart

Yes I can access the BIOS and change the boot order, the drive im trying to access is just not visible

Which kind of drive are you trying to install TrueNas on?

WD blue 500 GB

WD Blue SN550 NVMe SSD?

nop, it’s a HDD


I think Lars is right, that’s why I asked where you tried to install. I can image these systems to be pretty strict regarding what you can or cannot change.

Actually i did it one time, and realized just after that i couldn’t access my data because QNAP uses a different filesystem, so I reinstalled QTS, but since I backed up everything I want to reinstall truenas but I can’t figure out what am I doing wrong.

So it works, I just don’t know what is different

Try SCALE and boot it in UEFI mode? I’ve seen a handful of places where GRUB will make it magically show up and boot…

I tried too… but same problem

Any SecureBoot or similar restrictions in place? Enable CSM?

Unlikely to be the issue here, but it’s advised against to use HDDs as boot drive. If it’s a WD5000AAKX it’s a CMR drive so is good.

No secure boot option in the bios, and it’s written WD5000alzx but it looks like an aaks. Anyway i tried on an ironwolf of 10TB and one of 20TB and the issue is the same so I don’t thune it’s the hard drive.

WD5000AZLX is a CMR drive.
There might be software protecion that does not allow you from booting on anything else but the SATADOM port.

But I already did it in the past… what kind of drive should i try to boot on then?