No bootable device after TrueNAS fresh installation

The suggested boot drive is a SATA SSD or a NVMe SSD.

Any advice on which ssd and which adaptator for TS-453D?

What can you work with? I’m not clear about that QNAP internals.
Also, found a video and a written guide; they might help.

UPDATE:

I desperately check all the four disks in my nas while installing it (1 10TB, 1 500GB & 2 20TB) and it worked on both of the 20TB drives… I don’t understand why but it worked on these disks. But the problem is still here since i want the 20TB drives to store data and not to be the OS drives…

Did all four drives appear (detected) in the BIOS?

Did TrueNAS’s installation proceed on the 500 GB drive? (Even if it could not later boot.)

Yes, they all appeared with the right informations in the installation procedure and everything was fine, i didn’t see any error but as before, the drives that I tested before (the 10TB and the 500GB) just don’t show up in the BIOS

They appear during TrueNAS’s installation, when it prompts you to select a drive to install the OS?

…but they’re not detected in the BIOS?

Now I’m more confused. I feel like there’s an important detail missing here.

Exactly, they all appear during installation of TrueNAS but not in the BIOS,

Im as confused as you since i already did this before and it worked and I tested the drives separately in windows and they work…

Can you try something, just for kicks?

  1. Unplug all drives
  2. Plug only the 500 GiB drive into one of the ports previously used by a 20 TiB drive
  3. With only this one drive plugged in, at this particular SATA port, install TrueNAS
  4. See if it boots up properly into TrueNAS
1 Like

Ok, another update here, actually I didn’t test putting the drive in another slot… -_-

So the reason why the 2 20TB are detected in the BIOS is that they are in the first (or last i don’t know) slots of the NAS… I don’t know why it works this way or even why I didn’t test before but now it works, I just hope the other drives will be recognized in TrueNAS

So what you are saying makes sense, the 500GB in the port of the detected 20TB is detected.

Maybe it’s some dark magic proprietary nonsense enforced by the QNAP firmware? I have no idea.

1 Like

IDK, anyway, thanks everybody for helping me here. Have a good day.