Truenas boot drive corrupting on boot

I just moved my Truenas SCALE install from an old Dell desktop to a Dell R220. My boot drive is a simple SATA SSD, and my main drives are 2x 8TB Seagate Ironwolfs in a mirror, connected to onboard SATA ports.

I took an image the boot SDD and copied the config before moving the drives to the new server, just in case something went wrong.

When I boot the server with just the SSD in, it seems to have no problems regardless of the amount of times I reboot the server. But as soon as I install the data drives it boots once successfully. But then never again.

The first time I reboot it after installing the data drives (second boot overall) it gets stuck here:
image

The subsequent times I boot it, it gets stuck at a flashing cursor. Then eventually throws UEFI errors when trying to boot.

I have tried a variety of boot drives, both connected to the internal USB port, and the onboard SATA ports, and it seems to do the same thing every time.

I was running 23.10.2, but I tried updating to 24.04.1.1 still had the same issue.

I ran a memtest on the server to see if that was the issue (per some other posts I saw) and it came back fine.

Any suggestions?