Truenas core and nextcloud opening opcache to configure opcache.interned_strings_buffer

That command reaches out to Github and downloads it for you. Once that is done you can cd freenas-iocage-nextcloud to go into the directory.

I thought the script had to be configured and then run. I have downloaded and configured the script on my window computer using Visual studio. Now how can i get it to my truenas server? I am confused about this. Thank you

You just need to clone the directory, then cd into it, then create a file called nextcloud-config

That is the only file you need to edit.

I was able to download the script. I have tried to execute the script using script nextcloud.log ./ but i get one error Script started, output file is nextcloud.log
script: ./ No such file or directory
in the file scripts dataset, I see two things freenas-iocage-nextcloud folder and nextcloud.log. Am i supposed to do something else? Thank you

You need to do these three steps.

  1. git clone the script
  2. cd into the cloned directory
  3. create a file called nextcloud-config inside the directory and edit it with your preferred pool path, ip etc…

It is not the script that you configure. It is the config file called


I have done all this. I ran the execution but ran into issues and the script stopped. The software was not installed.

What does your nextcloud-config file look like? Can you share it here?

Also the nextcloud.log file?

When i try to send my nextcloud.log I get an error occurred: Sorry, new users can only put two links in a post. What can i do.

Can you copy and paste your nextcloud-config file?

here is my nextcloud-config file

And this file is inside the freenas-iocage-nextcloud folder?

BTW the time zone should be “America/Los_Angeles”

yes it is

Can you not copy past the log file also?

Your forgot to set the DNS_PROVIDER=cloudflare variable in the config file.

Ok I was able to install with the script but when i tried to log on it said it was not a secured connection. I then went to obtain a let’s encrypt cert by using iocage exec nextcloud /root/ I then received info saying using provided configuration {“config_file”: “/usr/local/www/Caddyfile”, “config_adapter”, “caddyfile”}. I went into my root@truenas inserted that command i was told not found. I then went into the root@nextcloud command and was given the same error. Can you please help? Thank you

Ok i got into the Caddyfile but am not sure what i need to change. The config_adapter does not show up in the Caddyfile. Thank you

Don’t worry about that. It’s just a message. It’s not an error.

I guess this setup did not completely install.

I got error + iocage exec nextcloud mysql -u root -e ‘CREATE DATABASE nextcloud;’
ERROR 2002 (HY000): Can’t connect to local server through socket ‘/var/run/mysql/mysql.sock’ (2)
Command: mysql -e CREATE DATABASE nextcloud; failed!

  • echo ‘Failed to create MariaDB database, aborting’
    Failed to create MariaDB database, aborting
  • exit 1

I would recommend deleting all the datasets, recreating them, and starting an install from scratch. The above error probably means your database hasn’t started when it tried to create it. The script should work flawlessly without error, at least last time I checked.