TrueNAS SCALE 24.04.1 is Now Available!

We are pleased to release TrueNAS SCALE 24.04.1!

This maintenance release includes improvements and fixes for issues discovered after the release of 24.04.0.

Notable changes:

  • Linux kernel updated to version 6.6.29 (NAS-128478).
  • Samba updated to 4.19.6 (NAS-128729, NAS-128410).
  • Rclone updated to version 1.65.2 (NAS-127485).
  • Fixes to address issues involving ZFS ARC cache and excessive swap usage leading to performance degradation (NAS-128988, NAS-128788).
    • With these changes, swap is disabled by default, vm.swappiness is set to 1, and Multi-Gen LRU is disabled. Additional related development is expected in the upcoming 24.10 major version of TrueNAS SCALE.
  • Automated migration to force home directories of existing SMB users from /nonexistent to /var/empty (NAS-128710).
  • Fixed network reporting numbers for apps (NAS-128471).
  • Fixed an issue where a TrueNAS system that has a VM configured with IPv6 bind addresses could disrupt the TrueNAS web interface (NAS-128102).
  • Intel ARC GPU firmware included to enable transcoding (NAS-127365).
  • Fix for starting apps with a bridge interface (NAS-127870).
  • Retrieve interface names not stored in the database on fresh install for reporting (NAS-128161).
  • Fixed stats logic on Installed apps page to prevent refreshing (NAS-128515).
  • Allow systemd to set ACLs on log files (NAS-128536).
  • Fixed bug in updating localization settings (NAS-128301).
  • Ensure newly created iSCSI targets are discoverable in HA systems (NAS-128099).
  • Improved workflow when FIPS settings are toggled on HA systems (NAS-128187).

See the Release Notes for more details.

Download :
Documentation :

Thanks for using TrueNAS SCALE! As always, we appreciate your feedback!


I know that jailmaker is not an official part of TrueNAS itself, but still worth mentioning, as I believe it can impact quite a few admins here:

After updating three of my machines to 24.04.1, the Tailscale jail fails to start automatically, shutting off my remote access (I did confirm this on one of those, directly accessible via SSH).

After the boot I can manually start the jail via shell, and Tailscale access is restored.

I have paused deploying 24.04.1 until I can get this sorted out.

P.S.: for now I have managed to work around the issue with a Post Init command, basically telling the system to wait two minutes and then to start the jail manually:

sleep 120s && /mnt/Tank/jailmaker/ start Tailscale

Of course, this should be modified to account for your particular dataset and jail names. Be sure to add the command before upgrading, if you depend on Tailscale for remote TrueNAS management, or you’ll be locked out. I was…

Also, as a precaution I put a long timeout value (300), to avoid having the system automatically stop the command during the initial 2-minute delay.


A special thank you to so many of our community users who helped to investigate and confirm fixes to issues. :pray:


The apps service completely failed to start when I upgraded to 24.04.1 :frowning:

The old toggle GPU fix didn’t work either.

Reverted to 24.04.0 and it started fine. I did grab a debug file if a ticket is needed.

Please do, we’ll take a look and see whats going on there.

Same here. Apps services failing. Are running apps on another vlan interface, saw an error on network problems before reverting.

Updated without a problem, thanks guys.

1 Like

When announcing minor releases I think it would be helpful to people evaluating whether to migrate, not just to list issues that are resolved but also to list issues with previous releases that are not yet resolved.

1 Like

The known issues list is available from the release notes linked in the announcement

1 Like

Apps failed also for me in 24.04.1 I am back to 24.04 until resolved tried 2 systems.
error in apps service, tried disable running apps, set pool etc before update to get same error “Application(s) have failed to start:list index out of range”

New Info : Solved
Deleted the 24.04.1 and boot on 24.04
I edited the lan interface and removed / deleted the Description
Hit update again.
After boot up everything was working on 2 systems.

After upgrade from TrueNAS-24.04.0 to TrueNAS-24.04.1 Plex official app stops transcoding 4kHDR10 to 1080p on ARC a380. Before upgrade works fine (multiple 4kHDR10 to 1080p HW accelerated transcodes) After rollback works again.

When i do 4kHDR transcode under SCALE 24.04.0 stats from intel-gpu-top looks like on this screen. Under SCALE 24.04.1 i got Video 0%, VideoEnhance 0%, Unknown 99% and no image is shown.

I did not make any drivers modifications after installing Arc A380. It was plug and play on 24.04.0.

Which firmware did you load previously for ARC to work? Was it different than the one we used here?

I am not aware of installing any firmware for ARC gpu. Is there a way to check what version I’m using? I am currently on version 24.04.0 which works fine.

24.04.0 didn’t have firmware included which worked for ARC transcoding AFAIK, so surprised it was on your system with no modifications before. Wondering how it was working then. Do you have onboard iGPU as well, what CPU you using?

I was also surprised that it worked.

CPU: Intel(R) Xeon(R) CPU E5-2680 v4 @ 2.40GHz
MB: Supermicro X10SRi-F (onboard ASPEED AST2400 BMC for IPMI)

Do you or @Belperite both have a description enabled on your bridge or vlan interfaces by any chance? What happens if you remove that description?

Ehhh - I still see multiple pod instances (with only 1 running) after a reboot. Catalogs are also requiring a manual refresh after a reboot. Seems some more work to be done here as I don’t think I’d see multiple pods created if they tried to start after the bridge was fully up.


Back to unset/reset of the pool after boot for me.

Unifi is no longer reporting 180gbps network utilization, plex remains at 0bps regardless if anything is stream or not - not 100% if that is a bug or a feature.

Let me know if you guys want a bug report or if someone already made one/is working on one.

Edit: created [NAS-129298] - iXsystems TrueNAS Jira for plex having 0 utilization.

@kris yes I did have. I’ve just tried removing all the descriptions but that didn’t make any difference.
I’ve got one physical interface, 3 vlans then 3 bridge interfaces off those.

Ok, we’ve identified an issue with descriptions on nics for sure. But if its not related to that then a bug ticket / debug might be required for us to dig in further.

Broke all of my apps. Reverting to Dragonfish-24.04.0 fixed it. Sorry, no time for further investigation just right now.

All my apps are from the Truecharts catalogue.