TrueNAS SCALE 24.04.2 is Now Available!

We are pleased to release TrueNAS SCALE 24.04.2!

This is a maintenance release and includes refinement and fixes for issues discovered after the 24.04.1 and 24.04.1.1 releases.

Notable changes:

  • Fixes implemented for CVE-2024-6387, noted as the “regreSSHion” vulnerability. Additional details and links to the technical discussion and analysis of the vulnerability are available from NAS-129828.TrueNAS SCALE Enterprise users should update to 24.04.2 as soon as possible to address this vulnerability.
  • Linux kernel updated to 6.6.32 (NAS-129293).
  • TrueNAS zfs synced with upstream OpenZFS 2.2.5-staging (NAS-129592).
  • Simplify file artifact generation that prevented debug generation with large numbers of files per directory (NAS-128779).
  • Fixed ACL form bug when directory services cache is disabled (NAS-129528).
  • Prevent app service disruption when the interface has a configured description (NAS-129150).
  • Show only pods which are running when retrieving choices for pod console access (NAS-128919).
  • Bug fix for cloud sync tasks with filename encryption (NAS-127485).
  • Fix range validator for apps config arguments (NAS-128590).
  • Fixed bug that caused cloud sync tasks to include the ix-applications dataset when it should have been excluded (NAS-129488).
  • Fixed bug that prevented editing the share Purpose for existing SMB shares (NAS-128987).
  • Allow configuration of a wider range of MTU values (NAS-129608).
  • Prevent Netdata and k3s log spam that caused excessive writes to the boot pool (NAS-129384 and NAS-129383).
  • Fixed ipmitool bug with updated IANA Enterprise numbers (NAS-128598).
  • Prevent 90 second shutdown timeout for VMs that are not started (NAS-129481).

See the Release Notes for more details.

Changelog: https://www.truenas.com/docs/scale/24.04/gettingstarted/scalereleasenotes/#24042-changelog
Download : https://www.truenas.com/download-truenas-scale
Documentation : https://www.truenas.com/docs/scale/24.04

Thanks for using TrueNAS SCALE! As always, we appreciate your feedback!

7 Likes

Thank you!

Does it include the fix to NAS-128913/NAS-128561 (zfs import takes 15minutes during boot)? To my understanding it was merged and was supposed to be in the next release but I am unable to find it in the changelog.

The NAS-128913 ticket is set to private, but the fix is included in 24.04.2

3 Likes

Cleaned up that ticket and made it public now.

2 Likes

Just an FYI, kind of odd the announcement above doesn’t mention the OOM and NFS issues. Those are rather important to those of us waiting to upgrade. I see by reading the tickets that it appears they are resolved with arc max now set to 85% and some other changes.

To me, those by FAR are the most important fixes in 24.0.2! I would think those would have made the list in the first post.

Agreed, and I’m not sure why they aren’t in the splash. I will have the team take a look.

Installed now, no network after boot ;_;
Even after rollback to 24.04.1.1
I have a bridge for jailmaker + everything else. But i can’t remove it since it is in use by apps.

Edit: I can see the link aggregation working, it changes from 0 to 2500.

Edit2: Got it going again after downgrading to 24.04, then to 24.04.1

updated without problems, yet another boring update for me :partying_face:

3 Likes

Updated 3 different Dragonfish systems. All three went well.

2 Likes

That is odd, especially since a rollback also didn’t work (the rollback is your previous boot environment 24.04.2 shouldn’t impact anything there).

Did you make any changes to your network / jailmaker setup a while ago on 24.04.1.1 and are just now rebooting for the first time?

24.04 vanilla did the trick. Not sure why!

Connection refused on the http/s ports after updating so I cannot reach webui. SSH works, VMs on the br0 are accessible too. Weird.

Update: I lied, http port works, just https is not working. I had forgotten which port I used for http since I never use it.

Update2: The https certificate was expired, I had forgotten to update the api token. I feel like I should have gotten an alert when it expired but anyway, it’s solved now.

1 Like

This is a first for me. I’m unable to install the update at all:

[EFAULT] Traceback (most recent call last): File "", line 198, in _run_module_as_main File "", line 88, in _run_code File "/tmp/tmptol5c1hf/truenas_install/__main__.py", line 795, in main() File "/tmp/tmptol5c1hf/truenas_install/__main__.py", line 483, in main exclude_list_file.write("\n".join(exclude_list).encode("utf-8")) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ UnicodeEncodeError: 'utf-8' codec can't encode characters in position 558-560: surrogates not allowed

Tried rebooting and updating again and no luck. No errors on boot pool with 20GB free.

Currently running 24.04.1.1.
SuperMicro X11SRM-F
Xeon W-2125
4X SuperMicro MEM-DR464L-CL02-LR26 64GB LRDIMM
Seasonic Focus 650W 80 Plus Gold
32X WDS200T2B0A 2TB SSD for storage
2x 32GB SATADOMs for boot
2x LSI 9400-16i

The kernel upgrade should fix a whole grab bag of issues too.

Unusual… I’d suggest waiting for a week to see if there are other users with a similar issue.
Its sometimes easier to diagnose if there is a pattern.
Perhaps start a separate thread??

1 Like

Glad this update has come out. I will install it probably tomorrow and take it for a spin. Thanks for the great work you folks at iXsystems.

1 Like

Update installed without issue on my secondary NAS (a UGREEN 6800). I’ll still probably wait a few days before installing it on my main NAS.

4 Likes

Update went without issue on my simple setup … just using Plex app and some SMB shares so far

2 Likes

All good on both NAS’s. One simple, one not so simple

2 Likes

No immediately obvious faults after update. Apps still try to deploy before bridge is setup causing duplicate pods, but I’m kinda used to tearing those down at this point after a reboot & they don’t impact anything if I forget.

…I’m going to jinx this one again & say “nothing is obviously broken”. 9/10

1 Like