Unable to install SCALE, able to install CORE


I am trying to install Truenas Scale on my new build.
AMD ryzen 3 4300G
Asrock Riptide B550
WD red 500gb SSD (boot drive)
and other drives

However, whatever I do, i cant get passed the USB boot menu. I keep getting the error:
unable to find a medium containing a live file system.
By now I think i tried everything: other BIOS settings, writing in DD and ISO.

while on the other hand i can install CORE

What can i do?

Have double checked the ISO matched the sha checksum provided on the download site?

How do I do that with Rufus?

I assume you are on windows if you are running Rufus, please correct me if I am wrong.

Command prompt

certutil -hashfile C:\file\path\my_file.exe SHA256

like this?

certutil -hashfile C:\Users\daand\Downloads 966cbd7c9e2cd04b7db388f9ea8c75c869cf22e9e1512554896e6f1b374ed121

I really dont know how

Nevermind, got it.

Yes, checksum is correct

This is an indication that you computer is looking for a UEFI boot system, but TrueNAS was installed in legacy BIOS mode.

  1. Go into BIOS settings and set it to ONLY boot UEFI.

  2. Then reinstall.

CSM enabled and only UEFI. Already tried that, did not do it.

This time I got:
Kernel panic syncing

Exactly. CSM is legacy boot. Disable it and try installing again.

Does not fix it

Hmmm. Perhaps I misunderstood the issue.

On reflection perhaps it is how you are writing the ISO to the USB flash drive. What tool are you using for this?

I am using Rufus:
DD mode

I find it very weird that I can install core and not scale

Since I am writing this usb flash drive exactly the same for core and scale

Assuming your issue is booting into the installer…

I would suggest disabling CSM, and installing UEFI if you get the chance.

Otherwise, try writing with a different program.

I used Balena Etcher last time.


I already tried all of that, installing with CSM enabled and disabled. And UEFI. I also already tried balenetcher.

I even updated the bios last night. Did not fix it

I do see the blue screen were the installer asks for the normal or 152000 baudrate. After that, a blinking cursor in the top left and after that the error.

Assume your BIOS is all up to date? 3.40? https://pg.asrock.com/mb/AMD/B550%20PG%20Riptide/index.asp#BIOS

yeah, installed it as an option, did not fix it.

Ok, you’ve test booted that same USB on another system? Does it boot up and the SCALE installer starts?

For what its worth, it should be written in dd mode specifically using Rufus.